Allow placeholders in email address searches

RESOLVED DUPLICATE of bug 542239

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 542239
12 years ago
8 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Details

Now we have shared queries, it should be possible to use placeholders in queries relating to people involved with the bug, such that the query returns different results for different people. E.g. (using pseudo-URLs to demonstrate the idea):

buglist.cgi?assigned_to=_me_&bug_status=ASSIGNED

This could be shared as a query "Bugs assigned to me" and would work correctly for anyone who ran it. (We could use _me_, $me, %me% or whatever.)

Gerv
This feature already exists, the possible values are "%reporter%", "%assignee%", "%qacontact%" and "%user%". See e.g. https://bugzilla.mozilla.org/buglist.cgi?bug_status=ASSIGNED&field0-0-0=assigned_to&type0-0-0=equals&value0-0-0=%25user%25 . It only works with the boolean charts, however.

http://www.bugzilla.org/docs/tip/html/query.html#pronouns
Oh - cool :-) Can we make it work for the standard email query UI? 

The most common use case is the %user% one - I can't see much demand for people regularly wanting to search for bugs where the assignee is the same as the QA contact. If we only did that one, I'd be happy.

Gerv

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542239
You need to log in before you can comment on or make changes to this bug.