grip cursor icons aren't fully adequate when resizing items

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
minor
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: snotling, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.10) Gecko/20060902 Firefox/1.0.4 (Debian package 1.0.4-2sarge11)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070130 Calendar/0.4a1

When you point the mouse on the border on a calendar item box, the cursor icon is correct "half the time" : only the "e-resize" and "n-resize" mode is supported.

Reproducible: Always

Steps to Reproduce:
1. go to calendar view
2. move your mouse pointer over the bottom or right border (depending on view rotation) of an item box
3. look at the cursor icon
Actual Results:  
cursor is :
 - over bottom border : north-resize icon
 - over right border : east-resize icon

Expected Results:  
cursor should be :
 - over bottom border : south-resize icon
 - over right border : west-resize icon

The CSS rules handle only 2 possibilities : vertical (n-resize) or horizontal (e-resize).
See <http://lxr.mozilla.org/mozilla1.8/source/calendar/base/themes/winstripe/calendar-views.css#177>
Whiteboard: [qa discussion needed]
Version: unspecified → Trunk

Comment 1

11 years ago
Confirmed on Mac OS X 10.4.8 as well. Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3pre) Gecko/20070301 Calendar/0.5pre

Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [qa discussion needed]

Comment 2

11 years ago
We may not be able to recreate this on Windows.
Status: NEW → ASSIGNED

Updated

11 years ago
Status: ASSIGNED → NEW
I can't reproduce this anymore on 1.0b1 (linux). Please reopen if its still the case.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.