netflix.com - Instant Viewing not supported on Firefox Linux

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
4 years ago

People

(Reporter: moz-bugzilla2, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
Netflix's new instant viewing does not support Firefox. It requires Internet Explorer 6+. Netflix needs to provide cross browser support. Please contact them and register your concern. Their system requirements list:

Your system is not compatible with instant viewing

Your current Internet browser is not compatible with instant viewing.

Please try again with Internet Explorer version 6 or higher.

To watch instantly, you need a computer with the following configuration:
Minimum Requirements

    * Computer running Windows XP with Service Pack 2 or higher, or Windows Vista
    * Internet Explorer version 6 or higher
    * Windows Media Player version 9 or higher
    * An active broadband connection to the Internet
    * 1.0 GHz processor
    * 512 MB RAM
    * 3 GB free hard disk drive space

Comment 1

11 years ago
Steve, is this still the case? I don't think it is, though I'm pretty sure they *do* require Windows.
(Reporter)

Comment 2

11 years ago
Their requirements still list that as the case (thou I am on Firefox on Mac at th moment). There is hope as Netflix said last summer:

"Bottom line: we're committed to giving all of our members access to our instant watching feature. Both Mac and Firefox are on the list."

-- From http://blog.netflix.com/2007/08/instant-watching-on-mac-firefox-and.html

Comment 3

11 years ago
Let's keep the pressure on them, shall we? :)

Does anyone know who this "Steve" guy at Netflix is? (I assume it's not the same Steve who filed the bug.)

cl

Comment 4

9 years ago
Hi All,

   While we are at it, please get NetFlix to support Firefox under Linux.

-T
(Reporter)

Comment 5

9 years ago
Instant Viewing now works on Firefox on Windows and Macs, so it seems Linux is the only remainder. While Netflix does not say they support instant viewing on Linux, has anyone tried installing Moonlight (Silverlight Linux implementation) on Linux and loading up Firefox with it?
OS: Windows XP → Linux
Summary: netflix.com - Instant Viewing requires Internet Explorer 6+ → netflix.com - Instant Viewing not supported on Firefox Linux

Comment 6

9 years ago
Installed novell-moonlight-1.0.1-i586 on FF 3.5.1 on CentOS 5.3.  Could not get past this.  Tried changing the user agent string to IE and XP, but got an Active X disabled screen.  Bummer.


Watching instantly on your computer

Our apologies — instant watching is not supported on this browser.
Complete System Requirements

To watch instantly, you'll need a computer that meets the following minimum requirements:

    * Windows
          o Windows XP with Service Pack 2, or Vista
          o Internet Explorer 6.0 or higher; or Firefox 2 or higher
          o 1.2 GHz processor
          o 512 MB RAM
    * Mac
          o An Intel-based Mac with OS 10.4.8 or later
          o Safari 3 or higher; or Firefox 2 or higher
          o 1 GB RAM

Comment 7

9 years ago
Can someone give this a try in Camino and/or Seamonkey? I'm curious to know how smart their UA sniffing actually is.

Comment 8

9 years ago
Changed my user agent to "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5".  Now I get to the point where it requests I install "Silverlight.exe".  So Netflix is not fooled into thinking "moonlight" is "silverlight.  Double bummer.

Comment 9

9 years ago
I just filed this bug at moonlight:
https://bugzilla.novell.com/show_bug.cgi?id=527439

Comment 10

9 years ago
Latest on the moonlight bug:
https://bugzilla.novell.com/show_bug.cgi?id=527439#c5

> The reason this is happening is due to an exception we throw at startup:

>System.NullReferenceException: Object reference not set to an instance of an
> object
>  at ln.a () [0x00000] 
>  at ln.b () [0x00000] 
>  at Netflix.Silverlight.SLPlayer.App.Application_Startup (System.Object A_0,
> System.Windows.StartupEventArgs A_1) [0x00000] 
>   at System.Windows.Application.OnStartup (System.Windows.StartupEventArgs e)
> [0x0000b] in
> /home/toshok/src/mono/moon/class/System.Windows/System.Windows \
> /Application.cs:527 
>  at System.Windows.Deployment.CreateApplication () [0x0016f] in
> /home/toshok/src/mono/moon/class/System.Windows/System.Windows \
> /Deployment.cs:368
>   at System.Windows.Deployment.AssemblyRegister (System.Reflection.Assembly
> assembly) [0x0002c] in
> /home/toshok/src/mono/moon/class/System.Windows/System.Windows \
> /Deployment.cs:290 
>   at System.Windows.Deployment.LoadAssemblies () [0x0008d] in
> /home/toshok/src/mono/moon/class/System.Windows/System.Windows \
>  /Deployment.cs:217 

> It's obviously not a very high priority to dive into the obfuscated IL to
> figure out exactly what's causing the NRE, since all it'll get us is
> the error dialog as opposed to the "upgrade silverlight" dialog.


> Look like Tech Evangelism is going to have to press Netflix on this one.

-T
Yes, I have asked them several times.

Comment 11

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.