Allow multiple tags to be set by a filter

RESOLVED FIXED in mozilla1.9alpha8

Status

MailNews Core
Filters
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Magnus Melin)

Tracking

({verified1.8.1.3})

Trunk
mozilla1.9alpha8
verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
From a mozillaZine suggestion. 

It would be nice if you could set multiple tags on a message as a filter action. Currently we disable the Tag action after you use it once.

Not sure we'll get to this for thunderbird 2. Leaving on the 1.9 radar for Thunderbird 3.

Comment 1

12 years ago
We disable every action once it's been chosen.  It might not be too hard to special case tags (and I'd think, copy message to)
Assignee: nobody → bienvenu

Comment 2

12 years ago
http://lxr.mozilla.org/mailnews/source/mailnews/base/search/resources/content/searchWidgets.xml#171

If we didn't add tag action to this list, I think we'd be OK. We'd need to double check that the backend supports multiple tag actions, but I can't see why it wouldn't.
(Assignee)

Updated

12 years ago
Duplicate of this bug: 341170
(Assignee)

Comment 4

12 years ago
The dupe suggests it will work (manual editing worked for him).
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 5

12 years ago
Created attachment 253855 [details] [diff] [review]
proposed fix

Not adding it to the list seems to work just fine.
Assignee: bienvenu → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #253855 - Flags: superreview?(bienvenu)
Attachment #253855 - Flags: review?(bienvenu)

Comment 6

12 years ago
Comment on attachment 253855 [details] [diff] [review]
proposed fix

thx, Magnus, that looks good.
Attachment #253855 - Flags: superreview?(bienvenu)
Attachment #253855 - Flags: superreview+
Attachment #253855 - Flags: review?(bienvenu)
Attachment #253855 - Flags: review+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed]

Comment 7

12 years ago
Seems to be working...

...maybe it would now be possible to disable used tags.

Comment 8

12 years ago
Landed on trunk, with two slight coding style violations fixed. ;-)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
(Assignee)

Updated

12 years ago
Attachment #253855 - Flags: approval-thunderbird2?
(Reporter)

Updated

12 years ago
Attachment #253855 - Flags: approval-thunderbird2? → approval-thunderbird2+
(Assignee)

Updated

12 years ago
Whiteboard: [checkin needed (1.8 branch)]
(Reporter)

Updated

12 years ago
Keywords: fixed1.8.1.3
Whiteboard: [checkin needed (1.8 branch)]
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 ID:2007032620 during tests with Thunderbird 2 RC 1
Keywords: fixed1.8.1.3 → verified1.8.1.3
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.