Restored blank tabs can't be reopened once they're closed

VERIFIED FIXED

Status

()

VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: zeniko, Assigned: zeniko)

Tracking

({verified1.8.1.2})

unspecified
verified1.8.1.2
Points:
---
Bug Flags:
wanted1.8.1.x +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Steps to reproduce:
1. Set Firefox to show the windows and tabs from last time at startup
2. Open a blank tab
3. Close and restart Firefox
4. Load anything in the blank tab (e.g. www.google.com)
5. Close that formerly blank tab

Expected result:
That tab is listed under History -> Recently Closed Tabs and can be reopened.

Actual result:
It's gone, sorry, but thanks for trying...
(Assignee)

Comment 1

12 years ago
Created attachment 253806 [details] [diff] [review]
be somewhat more realistic about what a blank tab looks like
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
Attachment #253806 - Flags: review?(dietrich)
(Assignee)

Comment 2

12 years ago
Drivers: The patch is low-risk and would prevent a rare case of dataloss: this bug will mostly bite people having either about:blank as the homepage or having blank tabs open when restarting during an extension installation.
Flags: blocking1.8.1.2?
Comment on attachment 253806 [details] [diff] [review]
be somewhat more realistic about what a blank tab looks like

Looks good. Does this also fix bug 367052?
Attachment #253806 - Flags: review?(dietrich) → review+
(Assignee)

Comment 4

12 years ago
It doesn't fix the whole other bug, just one of the symptoms (see bug 367052 comment #2).
Whiteboard: [checkin needed]
(Assignee)

Comment 5

12 years ago
Comment on attachment 253806 [details] [diff] [review]
be somewhat more realistic about what a blank tab looks like

Drivers: Low-risk one-liner (see comment #2). Please move the flag over to approval1.8.1.3 should it be too late for the 1.8.1.2 release.
Attachment #253806 - Flags: approval1.8.1.2?
Comment on attachment 253806 [details] [diff] [review]
be somewhat more realistic about what a blank tab looks like

approved for 1.8, but this isn't a blocker and needs to land today if it's going to make it in.

a=dveditz
Attachment #253806 - Flags: approval1.8.1.2? → approval1.8.1.2+
Flags: blocking1.8.1.2? → wanted1.8.1.x+
(Assignee)

Comment 7

12 years ago
Dietrich or Gavin: thanks for a speedy landing.
Whiteboard: [checkin needed] → [checkin needed][checkin needed (1.8 branch)]
mozilla/browser/components/sessionstore/src/nsSessionStore.js 	1.5.2.44
mozilla/browser/components/sessionstore/src/nsSessionStore.js 	1.59
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
Whiteboard: [checkin needed][checkin needed (1.8 branch)]
verified using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2pre) Gecko/2007020604 BonEcho/2.0.0.2pre. Followed Simon's steps, and I get the expected results. Adding verified keyword.
Keywords: fixed1.8.1.2 → verified1.8.1.2
(Assignee)

Updated

12 years ago
Duplicate of this bug: 355253
Verified with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090617 Minefield/3.6a1pre ID:20090617031528
Status: RESOLVED → VERIFIED
Flags: in-litmus?
in-litmus+
https://litmus.mozilla.org/show_test.cgi?id=7796
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.