If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<SELECT> crashes composer/editor in nsLineBox::DeleteLineList

VERIFIED DUPLICATE of bug 37493

Status

()

Core
Editor
P3
critical
VERIFIED DUPLICATE of bug 37493
18 years ago
16 years ago

People

(Reporter: Andreas Franke (gone), Assigned: Kathleen Brade)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; Linux 2.2.10 i686)
BuildID:    M15 and latest nightlies, e.g. 2000042113 and 2000042309

Opening the above URL in composer crashes mozilla. This seems to be caused by
the <SELECT> element contained in that document.

Reproducible: Always
Steps to Reproduce:
1. go to http://www.mozart-oz.org/
2. select "Edit Page" from the File menu

Actual Results: composer window opens, then mozilla crashes with segv

Here's a piece of HTML code that triggers the bug:
<html>
  <body>
    <form>
      <select/>
    </form>
  </body>
</html>
If you replace the URL above with the file:/... URL for a local file
containing this, the result is the same.

The backtrace begins with
#0  0x0 in ?? ()
followed by "...in NSGetModule () from /components/libraptorhtml.so"
several times.

I submitted several talkback reports while tracking this down.
(Reporter)

Comment 1

18 years ago
Created attachment 7898 [details]
backtrace for http://www.mozart-oz.org/, build 2000042113

Comment 2

18 years ago
I think it's a little worse than that.. can you at all open a file from local
disk with filepicker? see bug 36842
(Reporter)

Comment 3

18 years ago
Yes, sure it's worse... ;-)
Well, I had seen bug 36842 before, but it seems to be something different:
- the stack traces do not show any similarities
- this bug already occurs in M15, whereas bug 36842 seems to quite new
For example, I can successfully open my homepage with the file picker with M15.
So these are completely different issues.

By the way, thanks for your tips about gdb. As you can see, it works... :)
I agree that the newest nightlies are really bad in terms of usability.
I'll have a look at bug 36842 and confirm it if I can reproduce something.

Comment 4

18 years ago
i've had three different stacktraces on it, terminatig with SIGSEGV or SIGILL
so the only certain thing is that it crashes. btw - first thing to do when
starting composer: uncheck sidebar.

Comment 5

18 years ago
the above server is down or something, I can't access the file. I'll try again 
later to see if I can get to the site
(Assignee)

Comment 6

18 years ago
I see this crash on a Mac build from today too.
Reassign to sfraser since he might already have a bug for this (but maybe not 
since this is a crashing bug so it may be different).
Assignee: beppe → sfraser
Keywords: crash
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → M16
(Assignee)

Comment 7

18 years ago
Created attachment 7925 [details]
test html file for loading in Composer

Comment 8

18 years ago
This is nothing that I have.
Assignee: sfraser → brade
(Reporter)

Comment 9

18 years ago
Created attachment 8125 [details]
better stack trace (including function symbols)
(Reporter)

Comment 10

18 years ago
Stack trace is the same. Marking duplicate.

#0  0x0 in ?? ()
#1  0x40cbab9c in nsLineBox::DeleteLineList ()
   from /build/dist/bin/components/libraptorhtml.so
#2  0x40c9aa93 in nsBlockFrame::Destroy ()
   from /build/dist/bin/components/libraptorhtml.so
#3  0x40c9889e in nsAreaFrame::Destroy ()
   from /build/dist/bin/components/libraptorhtml.so
#4  0x40d6d017 in nsComboboxControlFrame::Destroy ()
   from /build/dist/bin/components/libraptorhtml.so

*** This bug has been marked as a duplicate of 37493 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Summary: <SELECT> crashes composer (editor) → <SELECT> crashes composer/editor in nsLineBox::DeleteLineList

Comment 11

18 years ago
verified in 5/1 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.