Changed case in functions name "LoadMsgWithRemoteContent()" != "loadMsgWithRemoteContent()"

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
General
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: AlexIhrig, Assigned: Scott MacGregor)

Tracking

({verified1.8.1.4})

Thunderbird2.0
x86
Windows XP
verified1.8.1.4
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
In Mozilla_1.8.0_Branch the function is spelled "LoadMsgWithRemoteContent()", but in Mozilla_1.8_Branch the function is spelled "loadMsgWithRemoteContent()".

This case change breaks all Add-ons using the function (e.g. "Allow HTML temp").

Was it intended to change the case? Why?
Flags: blocking-thunderbird2?
(Reporter)

Comment 1

12 years ago
In LXR both the upper case and the lower case can be found in 1.8_Branch.
(Reporter)

Comment 2

12 years ago
Maybe it's a result of Bug 246077
(Reporter)

Comment 3

12 years ago
ah sorry - false Bug in comment #2

The problem could be the result of Bug 357321
(Assignee)

Comment 4

11 years ago
Moving off bugs that didn't make the deadline for Thunderbird 2. 
Flags: blocking-thunderbird2? → blocking-thunderbird2-
(Reporter)

Comment 5

11 years ago
5 weeks ago I've reported this Bug and today we've still no Thunderbird 2.0 RC candidate. IMHO the functions case change breaks the API.

Scott, you could give a one sentence statement, if this case change was intended or not? 
(Reporter)

Comment 6

11 years ago
5 weeks ago I've reported this Bug and today we've still no Thunderbird 2.0 RC candidate. IMHO the functions case change breaks the API.

Scott, you could give a one sentence statement, if this case change was intended or not?
(Assignee)

Comment 7

11 years ago
I found this addon by Alexander on the website:

https://addons.mozilla.org/thunderbird/1556/

There's a comment that says 'finaly fixed a bug with remote content code'. Does that mean you've worked around this in your extension?
(Assignee)

Comment 8

11 years ago
Created attachment 258710 [details] [diff] [review]
capitalize the function to keep it in sync with seamonkey
(Reporter)

Comment 9

11 years ago
(In reply to comment #7)
> There's a comment that says 'finaly fixed a bug with remote content code'. Does
> that mean you've worked around this in your extension?

At the moment (AllowHTMLtemp 1.0) the extension checks Thunderbirds version and build date to distinguish between the different cases.
(Assignee)

Comment 10

11 years ago
I can fix this for tb2 but you'd have to tweak your extension again. is that ok?
(Reporter)

Comment 11

11 years ago
I'll adapt the version/build check in the extension to match the correct case. Thanks
(Assignee)

Comment 12

11 years ago
Alexander, I apologize, but I'm still confused (it happens to me near release time :)). Would you like to see this patch still get checked in?

Thanks!
-Scott
(Reporter)

Comment 13

11 years ago
If the case change was not intended by any reason, than I'd like to see the checkin.
(Assignee)

Updated

11 years ago
Attachment #258710 - Flags: superreview?(bienvenu)

Updated

11 years ago
Attachment #258710 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 14

11 years ago
fixed branch and trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.4
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird2.0
(Reporter)

Comment 15

11 years ago
Just wondering, what is with these two code lines in LXR:

/mailnews/base/resources/content/mailWindowOverlay.js, line 2187 -- * loadMsgWithRemoteContent

/mailnews/base/resources/content/mailWindowOverlay.js, line 2190 -- function loadMsgWithRemoteContent()

Comment 16

11 years ago
didn't find it in lines 2187 and 2190, but lines 2278 and 2281

http://lxr.mozilla.org/mozilla/source/mail/base/content/mailWindowOverlay.js#2277

2277 /**
2278  * loadMsgWithRemoteContent
2279  *   Reload the current message, allowing remote content
2280  */
2281 function loadMsgWithRemoteContent()
(Reporter)

Comment 17

11 years ago
(In reply to comment #16)
> didn't find it in lines 2187 and 2190, but lines 2278 and 2281

/mail/  is not  /mailnews/

Comment 18

11 years ago
v.fixed based on code inspection
Keywords: fixed1.8.1.4 → verified1.8.1.4
You need to log in before you can comment on or make changes to this bug.