Fails to install with xpicleanup error message

RESOLVED FIXED

Status

()

Firefox
Installer
--
critical
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Dylan, Assigned: rstrong)

Tracking

({verified1.8.1.5})

2.0 Branch
x86
Windows Vista
verified1.8.1.5
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.1.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506)
Build Identifier: Firefox Setup 2.0.0.1

Installer is able to go through process up to install types.  However when it starts to actually install (indicated by the percentage bar) it fails around 25% with an error regarding nxpicleanup.exe.

Note that this is a brand new pc purchased a day earlier running windows vista home basic edition.

Reproducible: Always

Steps to Reproduce:
1.Open installer
2.Choose either custom or standard installation
3.Wait for error
Actual Results:  
This error occurs no matter how you run the program.  Eventually when it starts to install, it will crash.

Expected Results:  
Software should have installed correctly with no error messages.

Please help me!!!!  I can't take IE much longer!
(Reporter)

Comment 1

12 years ago
Created attachment 253887 [details]
screenshot of error message
(Reporter)

Updated

12 years ago
OS: Other → Windows Vista
Version: unspecified → 2.0 Branch
Maybe dupe of Bug 364710
(Reporter)

Comment 3

12 years ago
Created attachment 253888 [details]
A better resolution.  Sorry...
(Reporter)

Comment 4

12 years ago
Created attachment 253889 [details]
A better resolution.  Sorry...
Attachment #253887 - Attachment is obsolete: true
(Reporter)

Updated

12 years ago
Attachment #253888 - Attachment is obsolete: true
Dylan: Can you please let us know your PC brand? I have never seen this error message before in my Vista testing.
same kind of error message like we have in Bug 364710. So i will dupe this against 364710
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364710
(Reporter)

Comment 7

12 years ago
(In reply to comment #5)
> Dylan: Can you please let us know your PC brand? I have never seen this error
> message before in my Vista testing.

The brand is Acer

This is an Acer AST180-UD400B

Comment 8

12 years ago
Reopening per bug 364710 comment 10 and requesting blocking 1.8.1.3. This is a fairly common problem in the forums:

http://forums.mozillazine.org/viewtopic.php?t=516716
http://forums.mozillazine.org/viewtopic.php?t=517072

Both of those reports are also on Vista.
Status: RESOLVED → UNCONFIRMED
Flags: blocking1.8.1.3?
Resolution: DUPLICATE → ---
Summary: Fails to install with nxpicleanup error message → Fails to install with xpicleanup error message
dveditz: how do you want to handle this one... as an xpinstall bug since I would think that xpicleanup shouldn't be hanging around, as an installer bug where we need to kill xpicleanup, or something else?
I don't even know how xpicleanup is getting launched in this situation.

Confirming based on multiple reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.1.4? → blocking1.8.1.4+
Assignee: nobody → sspitzer
Robert, is there any chance you can help me by taking this bug?
Whiteboard: [at risk]
dveditz, what do you think about launching xpicleanup.exe and requesting elevation so that it will run successfully on Vista? I have no clue as to why it is getting launched either but this would at least do the right thing on Vista as far as launching xpicleanup.exe goes.
dan, robert: i think this Bug is a Dupe of 

Bug 369937 fix our code so that no files are stored in the "VirtualStore\Program Files\Mozilla Firefox" folder on Vista

and we have a patch for the xpicleanup thing for vista in :

Bug 370219 – add xpicleanup.dat to removed-files.in on trunk and MOZILLA_1_8_BRANCH
Neither of those fixes this bug and it is debatable whether we actually want to remove the xpicleanup.dat file on install or update. Even if we removed the xpicleanup.dat file on install the xpicleanup.exe process would already be running so it doesn't help in that instance. For this installer specifically we want to check if the file is in use and if it is display an error to the user and abort the install if the process can't be killed.
Created attachment 263071 [details] [diff] [review]
patch - work in progress

This will handle xpicleanup.exe and freebl3.dll ( Bug #364710 ) being in use as weel as fixes the newline in the error message ( Bug 373972 ). Still some cleanup to do as well as including changes for Thunderbird and Sunbird which I will do in this same bug.

This will take care of the installer portion and a followup bug should be created to figure out why xpicleanup.exe is launching, etc.
Assignee: sspitzer → robert.bugzilla
Status: NEW → ASSIGNED
Flags: blocking1.8.1.4+ → blocking1.8.1.5?
Created attachment 263397 [details] [diff] [review]
patch
Attachment #263071 - Attachment is obsolete: true
Attachment #263397 - Flags: superreview?(mscott)
Attachment #263397 - Flags: review?(sspitzer)
I'll go ahead and add nssckbi.dll per bug 365595
marcia, can I ask a favor?

Can you search hendrix for the list of files that have been reported as open when trying to install?  (How do you search hendrix?)

For example:

"Error opening file for writing: \r\n\r\nfreebl3.dll\r\n\r\nClick Retry to try
again, or\r\nCancel to stop the installation."

We've got three on the list:

nssckbi.dll
freebl3.dll
xpicleanup.exe
(In reply to comment #18)
> nssckbi.dll
> freebl3.dll
> xpicleanup.exe
> 

Results after a bugzilla/Henrix search:

firefox.exe <- Bug 364639
mozMapi32.dll <-Bug 340535
AccessibleMarshal.dll <-Bug 340535
MapiProxy.dll <-Bug 340535
\r\n\r\ncomponents\r\n\r\n <- Hendrix Feedback
nspr4dll\ <- Hendrix

Created attachment 263664 [details] [diff] [review]
patch

I found a problem with using the DisplayCopyErrMsg macro inside of the CopyFile Function which could cause the installer to hang.
Attachment #263397 - Attachment is obsolete: true
Attachment #263664 - Flags: superreview?(mscott)
Attachment #263664 - Flags: review?(sspitzer)
Attachment #263397 - Flags: superreview?(mscott)
Attachment #263397 - Flags: review?(sspitzer)
(In reply to comment #19)
> (In reply to comment #18)
> > nssckbi.dll
> > freebl3.dll
> > xpicleanup.exe
> > 
> 
> Results after a bugzilla/Henrix search:
> 
> firefox.exe <- Bug 364639
Software Update only.

> mozMapi32.dll <-Bug 340535
> AccessibleMarshal.dll <-Bug 340535
> MapiProxy.dll <-Bug 340535
All these are shared dll's and will need to be handled separately.

> \r\n\r\ncomponents\r\n\r\n <- Hendrix Feedback
This is a directory and is Bug 374710. This will need to be handled separately.

> nspr4dll\ <- Hendrix
Added

Updated

11 years ago
Attachment #263664 - Flags: superreview?(mscott) → superreview+
Comment on attachment 263664 [details] [diff] [review]
patch

r=sspitzer
Attachment #263664 - Flags: review?(sspitzer) → review+
Checked in to trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 378880
Attachment #263664 - Flags: approval1.8.1.5?
Flags: blocking1.8.1.5? → blocking1.8.1.5+
Comment on attachment 263664 [details] [diff] [review]
patch

approved for 1.8.1.5, a=dveditz for drivers
Attachment #263664 - Flags: approval1.8.1.5? → approval1.8.1.5+
checked into MOZILLA_1_8_BRANCH

Checking in browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.3.2.22; previous revision: 1.3.2.21
done
Checking in mail/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/mail/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.1.2.11; previous revision: 1.1.2.10
done
Checking in toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.2.2.13; previous revision: 1.2.2.12
done
Keywords: fixed1.8.1.5
Whiteboard: [at risk]
I ran Bon Echo's installer multiple times on a couple Vista machines (Ultimate and Home) today, and didn't run into this bug (as well as a few uninstalls in-between).  Replacing fixed1.8.1.5 keyword with verified1.8.1.5, based on my testing with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.5pre)
Gecko/20070710 BonEcho/2.0.0.5pre 
Keywords: fixed1.8.1.5 → verified1.8.1.5
Duplicate of this bug: 389709
You need to log in before you can comment on or make changes to this bug.