QuickTime plugin only plays 8 seconds of 3+ minute song

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: trishah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Here is a test page I created to demonstrate the problem: http://www.shadwoolley.com/music_test.html

If you open the above page in both FoxFire and Internet Explorer you can see (hear) the problem.

Both Windows Media Player and QuickTime point to the same audio/MP3 file.  But when FoxFire browser is used then only the first  8 seconds of the 3+ minute song will play.

I've looked at all the settings and checked FoxFire & QuickTime websites for help but I found nothing about this exact problem. 

I've checked all of QuickTime settings a number of times and can't find anything wrong with them.

I have installed the latest build of Firefox and got the same results.

I posted on Experts-Exchange.com and a tech there tried to reproduce the problem but QuickTime in Firefox worked fine for him.

I installed the "IE emulator" where after install you go the the webpage and press Crl-Alt-C to reload the page so the server thinks you are using IE not FireFox... In this case the controls of the QuickTime plugin look sorta like WindowsMediaPlayer (but not exact) AND the song plays all the way through!  But when the page is reloaded with QuickTime, same problem.

I worked through the help page on Firefox site where I deleted plugins from both FireFox and QuickTime installation folders... this didn't work either.

My config:
WinXP Pro
FoxFire: 2.0.0.1
IE: 7.0.5730.11
QuickTime: 7.1.3.100
Windows Media Player: 11.0.5721.51.45

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.shadwoolley.com/music.html using Firefox browers
2. Play song using QuickTime
3. Note: because the tech at Expert-exchange could not reproduce the problem this may be specific to something on my system.
Actual Results:  
Only 8 seconds of the 3+ minute song plays.  Slider goes to end in 8 seconds.

Expected Results:  
Song should play all the way through as it does when QuickTime is used in IE.

My config:
WinXP Pro
FoxFire: 2.0.0.1n (latest nightly build)
IE: 7.0.5730.11
QuickTime: 7.1.3.100
Windows Media Player: 11.0.5721.51.45
(Reporter)

Comment 1

12 years ago
I have been working on this problem with a couple other people and no one but me has the problem so it must be something with my system.  What I have discovered is that it also happens for mpg video files.

If the song is opened in QuickTime outside of FireFox the song plays fine.
(Reporter)

Comment 2

12 years ago
Okay, the tech over at experts-exchange.com figured it out... here is what solved it...

"Go to your Zone Alarm Control Panel Privacy > Main panel and there turn off  all  of your main privacy blocking.  Go to the Privacy > Cache Cleaning tab and clear the cache.

Now clean your browser cache.  In Firefox 2: "Tools -> Options -> Advanced -> Network / Cache -> Clear Now"

From My Firefox though the path is Tools->Options->Privacy->Private Data->Settings to confirm that Cache is set and then Clear Now."

After this the QuickTime plugin to FireFox plays the song all the way through.

Here is the link to the whole process we tried: http://www.experts-exchange.com/Software/Internet_Email/Web_Browsers/Mozilla/Q_22146320.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.