Closing "popped-out" gmail chat window is not recognized by gmail's "owner window"

VERIFIED DUPLICATE of bug 370096

Status

VERIFIED DUPLICATE of bug 370096
12 years ago
11 years ago

People

(Reporter: jonkelling, Assigned: stuart.morgan+bugzilla)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3

1) If you click to "Pop Out" a chat window in Gmail, a new window will be opened from Gmail's main page.
2) If you close Gmail's main page while you have chat windows "Popped Out," you will receive a JavaScript alert saying "All chat windows that have been popped out will be closed."
3) In Camino, if you close all popped out chat windows, you still receive the alert when closing the main page, while in other browsers you don't.

Reproducible: Always

Steps to Reproduce:
1) Login to Gmail
2) Click to "chat" with someone in your contacts list
3) Click "Pop Out" to open a new window for that chat
4) Close the "Popped Out" chat window
5) Close Gmail's main window
Actual Results:  
Received JavaScript alert "All chat windows that have been popped out will be closed."

Expected Results:  
Should not have received alert.

Comment 1

12 years ago
This smacks of a Gmail bug. Does it happen with Firefox, too?

cl
(Reporter)

Comment 2

12 years ago
Nope, doesn't happen in FireFox. I'm running version 2.0.0.1.
(Reporter)

Comment 3

12 years ago
Just found out that this doesn't happen in Camino if you click the "Pop In" button on the chat window. It ONLY happens if you close the window with File > Close Window or File > Close Tab.

Comment 4

12 years ago
Is this still a problem using Gmail with Camino 1.5?

cl

Updated

12 years ago
Whiteboard: CLOSEME 6/13
(Assignee)

Comment 5

12 years ago
I have a suspicion about what's going on here (I think we aren't triggering unload actions when closing a tab); I'll look into it.
Assignee: nobody → stuart.morgan
Whiteboard: CLOSEME 6/13
(Assignee)

Comment 6

11 years ago
It's actually the onbeforeunload that should be catching that, so this is a dup of bug 370096.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370096

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.