Java XPCOM glue doesn't work when built with gcc 4.x

RESOLVED WORKSFORME

Status

Core Graveyard
Java to XPCOM Bridge
RESOLVED WORKSFORME
11 years ago
3 years ago

People

(Reporter: glandium, Assigned: jhp (no longer active))

Tracking

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 254067 [details] [diff] [review]
easy workaround

The javaxpcom glue doesn't work when built with gcc 4.x because in such cases symbols are hidden by default and the JNI glue doesn't export the necessary symbols. I've been using a workaround, that I'll attach here for documentation purpose, with success for a few months.
(Assignee)

Comment 1

11 years ago
Well, I've been building with GCC 4.1.2 on Ubuntu with no problems.  There are only three methods in the glue lib that should be external, and all those are declared as NS_EXPORT, which makes them visibility == "default" (that is, not hidden).
(Reporter)

Comment 2

11 years ago
on which branch ?
(Assignee)

Comment 3

11 years ago
On the trunk and MOZILLA_1_8_BRANCH (1.8.1.x).
(Reporter)

Comment 4

11 years ago
I can confirm this works on MOZILLA_1_8_BRANCH
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.