All users were logged out of Bugzilla on October 13th, 2018

redeclaration of document.URL using __defineGetter__

VERIFIED DUPLICATE of bug 44013

Status

()

P3
normal
VERIFIED DUPLICATE of bug 44013
19 years ago
17 years ago

People

(Reporter: norrisboyd, Assigned: rogerl)

Tracking

({js1.5})

Trunk
x86
Windows NT
js1.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Subject: 
        BUG: redeclaration of document.URL using __defineGetter__
   Date: 
        Fri, 21 Apr 2000 17:14:08 +0300
   From: 
        Georgi Guninski <joro@nat.bg>
     To: 
        Norris Boyd <norris@netscape.com>




It is possible to redeclare document.URL using __defineGetter__ (it is
impossible with normal getter).
The code is:
-----------------------------------------------------
<HTML>
<SCRIPT>
// document.URL getter = function() { return "http://www.yahoo.com"} //
This gives the error "redeclaration of const. URL"
document.__defineGetter__("URL",function() {return
"http://www.yahoo.com"} );
alert("document.URL="+document.URL);
</SCRIPT>
</HTML>
-----------------------------------------------------
D'oh -- JS2 syntax does not include getter=, wherefore __defineGetter__, which I 
forgot about completely.  That needs to call OBJ_CHECK_ACCESS(... JSACC_WATCH..) 
too, a la the interpreter JSOP_GETTER:JSOP_SETTER: case.

/be
Bulk reassigning most of norris's bugs to mstoltz.
Assignee: norris → mstoltz
(Assignee)

Comment 3

19 years ago
engine issue...
Assignee: mstoltz → rogerl
Component: Security: General → Javascript Engine
QA Contact: junruh → pschwartau

Updated

19 years ago
Keywords: js1.5
I believe I fixed this already.  Someone please verify.

/be
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Dup of bug 44013.

/be
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 44013 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Marking Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.