Bon Echo nighty will not run on win9x

RESOLVED FIXED

Status

()

Firefox
General
--
blocker
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Richard, Assigned: rstrong)

Tracking

({verified1.8.1.2})

2.0 Branch
x86
Windows 98
verified1.8.1.2
Points:
---
Bug Flags:
blocking1.8.1.2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.8.0.9) Gecko/20061211 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.8.0.9) Gecko/20061211 SeaMonkey/1.0.7

update my nighty Bon Echo from 5th Feb to todays it refuses to run.
Vista checkins maybe !

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
 Bon Echo runs on win9x
(Reporter)

Updated

11 years ago
Severity: normal → critical
Confirmed, downloaded latest-mozilla1.8's .zip on Win98 and it does nothing at all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.1.2?
(Reporter)

Updated

11 years ago
Severity: critical → blocker
Created attachment 254220 [details] [diff] [review]
patch
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #254220 - Flags: review?

Updated

11 years ago
Flags: blocking1.8.1.2? → blocking1.8.1.2+

Comment 3

11 years ago
Marcia/Juan:  We need to verify that this works for Windows 98 and ME once Rob lands his patch.  Please add it to the priority list of bugs to verify with RC1.
Comment on attachment 254220 [details] [diff] [review]
patch

r=dveditz
Attachment #254220 - Flags: review? → review+
Comment on attachment 254220 [details] [diff] [review]
patch

This is only needed on the branch since the trunk only supports versions of Windows with DuplicateTokenEx
Attachment #254220 - Flags: approval1.8.1.2?

Comment 6

11 years ago
Comment on attachment 254220 [details] [diff] [review]
patch

Approved for the 1.8 branch, a=jay.  Let's get this landed so QA/community can retest with tomorrow's nightlies (or RC1 if we get it).
Attachment #254220 - Flags: approval1.8.1.2? → approval1.8.1.2+
Blocks: 369465
fwiw, r=sspitzer as well.  testing robert's 98.exe build now on Windows 98
I have a windows 98 box (actually, it is QA's, thanks marcia!), but it is running an un-service-packed version (4.10.1998) of windows 98.

when I run robert's new 98.exe on it, I fail, but not because of DuplicateTokenEx().

I fail because firefox.exe is linked to missing export OLEAUT32.DLL -77

same is true with a branch build before robert's changes.

robert believes that we need a version of windows 98 with service packs to properly test this.
(In reply to comment #6)
> (From update of attachment 254220 [details] [diff] [review])
> Approved for the 1.8 branch, a=jay.  Let's get this landed so QA/community can
> retest with tomorrow's nightlies (or RC1 if we get it).
I'm going to hold off for the tree to stop burning.
Checked in to MOZILLA_1_8_BRANCH - not needed for the trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.2
Resolution: --- → FIXED
Version: unspecified → 2.0 Branch
(Reporter)

Comment 11

11 years ago
Sorry Feb7th build will not run on win98se 
fully updated 
   
Created attachment 254372 [details] [diff] [review]
followup patch -w

Followup patch for additional issues found
Attachment #254372 - Flags: review?(sspitzer)
Created attachment 254374 [details] [diff] [review]
patch with whitespace changes
Comment on attachment 254372 [details] [diff] [review]
followup patch -w

r=sspitzer, nice!

I also tested builds from robert on windows 98.

I was able to install, run, and do updates
Attachment #254372 - Flags: review?(sspitzer)
Attachment #254372 - Flags: review+
Attachment #254372 - Flags: approval1.8.1.2?

Comment 15

11 years ago
Comment on attachment 254372 [details] [diff] [review]
followup patch -w

Approved for 1.8 branch, a=jay.
Attachment #254372 - Flags: approval1.8.1.2? → approval1.8.1.2+
Additional patch checked in to MOZILLA_1_8_BRANCH - not needed on the trunk

Comment 17

11 years ago
tested using tinderbox zip builds, windows is win98 SP1 with some Updates, like IE5.5

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.2pre) Gecko/20070207 BonEcho/2.0.0.2pre

Not working: 1.8.1.2pre: 2007020703 filetime 04:57:28
    Working: 1.8.1.2pre: 2007020703 filetime 19:48:02

Seems Bug 305233 is fixed for trunk only (I can't test trunk, so I won't download)

Bug 305233 – pacifica tinderbox builds and Talkback.exe have wrong buildID, taken from last nightly
Verified fixed for 1.8.1.2 using a Windows 98 Install running as VM.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.2pre)
Gecko/2007020804 BonEcho/2.0.0.2pre

I can launch and use the BonEcho nightly on Windows 98.
Keywords: fixed1.8.1.2 → verified1.8.1.2
You need to log in before you can comment on or make changes to this bug.