Closed Bug 369535 Opened 15 years ago Closed 15 years ago

Window Vista Business - Firefox 2 - HTTP GET Request failed, but it works in IE7 :S

Categories

(Firefox :: Shell Integration, defect)

2.0 Branch
x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 363997

People

(Reporter: orlandopozo, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

The URL is the following:

http://www.bigbucksurveys.com/mrsurvey.cfm?ref=39985&q389=Hammer&q390=Black&q391=73+Conrad+Road&q392=Marlborough&q393=xx&q394=01752&q395_area=508&q395_exch=486&q395_num=9806&q432_month=03&q432_day=04&q432_year=1949&q433=eblack%40gstone.com&q434=m

Making the HTTP GET Request in IE7 works, but in Firefox 2, it doesn't work, it keeps loading, the ethereal network analyzer said this after the request:

TCP Retransmission (In my point of view, Firefox 2 tries to restransmit the HTTP GET Request, but nothing happen, the user interface says "Loading...")

This is the HTTP GET Request Header sent by Firefox 2:

--------------------------------

GET /mrsurvey.cfm?ref=39985&q389=Hammer&q390=Black&q391=73+Conrad+Road&q392=Marlborough&q393=xx&q394=01752&q395_area=508&q395_exch=486&q395_num=9806&q432_month=03&q432_day=04&q432_year=1949&q433=eblack%40gstone.com&q434=m HTTP/1.1

Host: www.bigbucksurveys.com

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Referer: http://www.theuseful.com/xg?preview=2358&previewkey=iDX9ljcZ&previewlive=1

--------------------------------

This is the HTTP GET Request Header sent by Internet Explorer 7:

--------------------------------

GET /mrsurvey.cfm?ref=39985&q389=Hammer&q390=Black&q391=73+Conrad+Road&q392=Marlborough&q393=xx&q394=01752&q395_area=508&q395_exch=486&q395_num=9806&q432_month=03&q432_day=04&q432_year=1949&q433=eblack%40gstone.com&q434=m HTTP/1.1

Accept: */*

Accept-Language: en-us

UA-CPU: x86

Accept-Encoding: gzip, deflate

User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506)

Host: www.bigbucksurveys.com

Connection: Keep-Alive

Cookie: CFID=9406553; CFTOKEN=62610283; SIPX=%2D2142739522

--------------------------------

and this the HTTP response header sent back to Internet Explorer 7

--------------------------------

HTTP/1.1 200 OK

Connection: close

Date: Tue, 06 Feb 2007 20:22:29 GMT

Server: Microsoft-IIS/6.0

X-Powered-By: ASP.NET

Set-Cookie: SIPX=%2D2142739522;path=/

Content-Type: text/html; charset=UTF-8

--------------------------------

I tried to tamper (https://addons.mozilla.org/firefox/966/) the HTTP request from firefox in order to match the HTTP request headers that Internet Explorer 7 is using, but I got the same result.

Reproducible: Always

Steps to Reproduce:
1. Access this URL

http://www.bigbucksurveys.com/mrsurvey.cfm?ref=39985&q389=Hammer&q390=Black&q391=73+Conrad+Road&q392=Marlborough&q393=xx&q394=01752&q395_area=508&q395_exch=486&q395_num=9806&q432_month=03&q432_day=04&q432_year=1949&q433=eblack%40gstone.com&q434=m

Using Firefox 2 on Window Vista Business.
I believe this may be a dupe of Bug 363997.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is there a reason this is marked security-sensitive?
Perhaps the reporter checked it by mistake. Removing the checkmark.

(In reply to comment #2)
> Is there a reason this is marked security-sensitive?
> 

Group: security
> Is there a reason this is marked security-sensitive?

Sorry about that
orlandopozo: can you take a look at https://bugzilla.mozilla.org/show_bug.cgi?id=363997 comment#6 and comment#8, there is a simliar problem described. 

Does this steps from Bug 363997 help you to fix your reported problem ?
OS: Other → Windows Vista
Version: unspecified → 2.0 Branch
Yes, mainly the comment # 6 from Frank Racis.

Comment # 6 URL: https://bugzilla.mozilla.org/show_bug.cgi?id=363997#c6
RFC (TCP Extensions for High Performance): http://www.faqs.org/rfcs/rfc1323.html

I modified the TCP window scaling from 2 to 4 using this command:

netsh interface tcp set global autotuninglevel=restricted (window scaling 4)

However, I couldn't rollback the change in order to demonstrate the bug, I tried to change the TCP window scaling from 4 to 2 using this command:

netsh interface tcp set global autotuninglevel=highlyrestricted (window scaling 2)
i will mark this as a dupe of Bug 363997 
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 363997
You need to log in before you can comment on or make changes to this bug.