Japanese(Shift_JIS) char coding menu missing on Linux, random others missing on other platforms

VERIFIED FIXED in M17

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Charles Wang, Assigned: cata)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] I have fix in my tree, you can see the diff here)

(Reporter)

Description

18 years ago
Ovserved on 2000-04-24-09-M16 comm build.

steps to reproduce:

1. Choose View via task bar
2. Character Coding-->Mutibyte

actual result:Japanese (Shift_JIS) text is missing from Multibyte's listing.
Expected result:Japanese (Shift_JIS) text should be listed if clicking Multibyte 
label
(Reporter)

Updated

18 years ago
Summary: Character Coding's Multibyte is missing Japanese (Shift_JIS) text → Character Coding's Multibyte is missing Japanese (Shift_JIS) text

Comment 1

18 years ago
Is that true the Shift_JIS move other places in the menu ? Is that esay to spot 
or not ?
cata can you talk to cwang about this issue. Is this the *feature* that you 
implement the dynamic menu ? 
Assignee: ftang → cata

Comment 2

18 years ago
reassign to cata
(Assignee)

Comment 3

18 years ago
This should be fixed as today's build. Works fine in my tree. Please let me know 
if we have any problems.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

18 years ago
On my linux machine, it only shows Japanese-2022-JP and Japanese(UEC-JP)on 
todays build.
(Assignee)

Comment 5

18 years ago
Damn! Are you sure it is today's tree? I checked in this code last night. Any 
chance it didn't pick up the changes?
(Reporter)

Comment 6

18 years ago
It is missing only linux's build althouhg Cata marks fixed. I am going to watch 
it for the coming builds. XiangLan, would you please check your linux for this 
behavior on today's build? 

Comment 7

18 years ago
Yes, it is missing on my linux build too. It shouldn't be a machine specific problem
(Reporter)

Comment 8

18 years ago
Thanks. If tomorrow is the same, we have to reopen this bug.

Comment 9

18 years ago
This still happens in 2000042509 Linux build.  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: --- → M17

Updated

18 years ago
Keywords: nsbeta2

Comment 10

18 years ago
FYI, there's an extra Simp Chinese (GB2312) char coding menu in Linux bld. 
Editing Summary from "Character Coding's Multibyte is missing Japanese 
(Shift_JIS) text" to "Japanese(Shift_JIS) char coding menu missing in Linux bld"
Summary: Character Coding's Multibyte is missing Japanese (Shift_JIS) text → Japanese(Shift_JIS) char coding menu missing in Linux bld

Comment 11

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]

Comment 12

18 years ago
Similar problem in mail compose, gb2312 is missing from the menu (saw this in 
win32 build).

Comment 13

18 years ago
Another problem in mail view, ISO-8859-1 is missing from the menu (saw this in 
win32 build).
(Assignee)

Comment 14

18 years ago
I'm chasing this baby as we speak...
(Assignee)

Comment 15

18 years ago
I have a fix for this:

S:\mozilla\intl\uconv\src>cvs diff -c *.cpp
Index: nsCharsetMenu.cpp
===================================================================
RCS file: /cvsroot/mozilla/intl/uconv/src/nsCharsetMenu.cpp,v
retrieving revision 1.32
diff -c -r1.32 nsCharsetMenu.cpp
*** nsCharsetMenu.cpp   2000/05/16 22:19:00     1.32
--- nsCharsetMenu.cpp   2000/05/18 23:11:50
***************
*** 942,948 ****
      // if this charset is not on the accepted list of charsets, ignore it
      PRInt32 index;
      res = aDecs->GetIndexOf(atom, &index);
!     if (NS_SUCCEEDED(res) && (index > 0)) {

        // else, add it to the menu
        res = AddCharsetToContainer(aRDFServ, aCCMan, aArray, aContainer, atom,

--- 942,948 ----
      // if this charset is not on the accepted list of charsets, ignore it
      PRInt32 index;
      res = aDecs->GetIndexOf(atom, &index);
!     if (NS_SUCCEEDED(res) && (index >= 0)) {

        // else, add it to the menu
        res = AddCharsetToContainer(aRDFServ, aCCMan, aArray, aContainer, atom,

Bob, how can we get this evaluated and checked in?
Guys, thanks a lot for catching this bug! Nasty one...
Whiteboard: [nsbeta2+] → [nsbeta2+] I have fix in my tree, you can see the diff here
(Assignee)

Updated

18 years ago
OS: Linux → All
(Assignee)

Comment 16

18 years ago
Fixed...
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Updated

18 years ago
Summary: Japanese(Shift_JIS) char coding menu missing in Linux bld → Japanese(Shift_JIS) char coding menu missing on Linux, random others missing on other platforms

Comment 17

18 years ago
*** Bug 41304 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
I verified this in 2000-06-02-08 Linux build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.