granparadiso-alpha1 unable to load libstdc++.so.5

RESOLVED INVALID

Status

()

Firefox
Shell Integration
--
critical
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Peter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070131 Fedora/1.5.0.9-2.fc6 Firefox/1.5.0.9 pango-text

Platform: Fedora Core 6
All my software meets or exceeds the specifications for FC6 in
http://developer.mozilla.org/en/docs/Linux_Compatibility_Reference

Installed this version from tarball: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/granparadiso/alpha1/linux-i686/en-US/granparadiso-alpha1.tar.bz2

./firefox & returns "error while loading shared libraries: libstdc++.so.5"

I, of course, have libstdc++.so.6, which is listed in the Compatibility Reference as the standard for FC6.  The usual trick of tricking the executable by creating a symlink named with the earlier version doesn't work; firefox-bin then complains that it can't find the symbols GLIBCPP_3.2 and CXXABI_1.2 in what it thinks to be so.5, but is of course so.6.


Reproducible: Always

Steps to Reproduce:
1. Install granparadiso-alpha1 to desktop directory with that name
2. In shell, cd to granparadiso-alpha1 and run ./firefox &
3. firefox-bin returns the errors above and fails
I'm not speaking from experience, but it seems like you are missing 
compat-libstdc++-33

Comment 2

11 years ago
Receiving the same error message as Peter the submitter above.

Steps to reproduce.

1) Install Fedora Core 6 I downloaded in Dec.
2) Then update all installed packages: Navigate to Applications | System Tools | Software updater tool to update all packages 
3) Download Firefox 2 from Mozilla web site
4) extract tar file and run ./firefox

The error message "./firefox-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory"

5) tried Arie's suggestion and went to Applications | Add/Remove Software and searched for the package 'compat-libstdc++-33' and updated suggested package
6) Tried running ./firefox again and now it works.

As steps 1 to 4 are what a normal user on the net would do. In my opinion this is still a bug eventhough Aries suggestion fixes it. (ie. I spent the last 2 days searching many forums for solutions and was only able to find it here. Most users would give up and keep using Firefox 1.5 which comes with FC6)

Regards, good bug Peter.
No response from reporter in 2 months and this is not a bug in Firefox -> Marking Invalid

@jmarbas: The libstdc++5 requirement is specified in the system requirements at http://www.mozilla.com/en-US/firefox/system-requirements.html and the first result of a Google search for [firefox error libstdc++.so.5] is a Mozillazine kb entry with directions to solve this exact error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.