Prefill should occur with ONDOMLOAD, but seems like ONLOAD

RESOLVED DUPLICATE of bug 221634

Status

()

RESOLVED DUPLICATE of bug 221634
12 years ago
10 years ago

People

(Reporter: justizin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3 (MultiLang)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3 (MultiLang)

I have passwords saved from years of browsing for all sorts of sites.  I've grown to expect the password to be filled if I remotely recognize a site's logo or layout.  The problem is, the password is _NOT_ filled while the page is drawing, I have thousands of awkward moments every week where I have to wonder until the page has finished loading, javascript has been parsed, etc.. before I can determine if my keychain is mounted.

I'm pretty sure somewhere in the realm of the document's onload event, password manager is hooking in, and I am also growing confident that it should be happening, oh, say, around or after ONDOMLOAD handlers..

In short: before the form is drawn, it should be pre-filled, in part to prevent people from typing a username and password before the prefill.

Reproducible: Always

Steps to Reproduce:
1. Visit a site
2. Log in
3. Be sure to save your password!
4. Close browser or log out of the site
5. Visit the site again
6. Watch the login form render
Actual Results:  
You'll have an opportunity to type before the remembered info is prefilled

Expected Results:  
Prefill should occur prior to rendering of interactive widgets, as would happen for the "value" attribute of an INPUT element.

I understand there may be a good reason in today's codebase why this can't change immediately, though I'd like to hear it, and nonetheless, this problem eventually needs to be solved somehow to meet reasonable expectation of responsiveness and to cater to the development of muscle memory and related reflexes, and to prevent people from typing over their prefill password.
This bug is fixed in Firefox 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 221634
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.