Mozilla Firefox lists "Mozilla" as Publisher in Control Panel

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
12 years ago
8 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +
wanted1.8.1.x +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Seen while testing Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/2006120418 Firefox/2.0.0.1.

STR:

1. Go Control Panel | Programs and Features | Uninstall or Change Programs
2. Review Publisher information for Firefox
3. Note that Publisher is Mozilla, not Mozilla Corporation

Expected:

This should match the Firefox EULA.

Not sure if this will be fixed with signing for 2002, adding preed. Attaching screenshot as well.
Win XP has a different layout than Vista, but also lists Mozilla as the publisher. Maybe this is by design?
Using today's Vista build, which is signed -  Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/2007020823 Firefox/2.0.0.2, we show Firefox/Mozilla Corporation/http://www.mozilla.org in the Default Programs box, but in the area cited in my initial comment, which is the Uninstall, it still reads Mozilla.
nominating to get this on the radar. I don't want to lose track of it, and we should definitely fix before we ship Firefox 3.
Flags: blocking1.8.1.3?
Moving flag to firefox3. Would approve a patch, but need an owner
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.4?
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: [wanted-firefox3]
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]
I see that current nightly still shows Mozilla, as does the release version.
Version: 2.0 Branch → Trunk
It seems to me that the problem is with the installation process. When browsing the Windows Registry, the key HKML/SOFTWARE/Microsoft/Windows/CurrentVersion/Uninstall/Mozilla Firefox (any version installed), the Publsiher shown is "Mozilla". All this data is populated on the setup process of any application -only if this uses the standard Windows Setup API or the Windows Installer service-.

As I don't have access to the Firefox installer source code, my proposed patch is either review the installer source code or create an Windows Installer package.

I will follow this bug and, if time permits it to me, participate in its solution.
In line 444 on file http://mxr.mozilla.org/mozilla2.0/source/browser/installer/windows/nsis/shared.nsh

Just replace "Publisher" "Mozilla" 0
with "Publisher" "Mozilla Coporation" 0

Hope that will solve the problem.
Created attachment 539227 [details] [diff] [review]
File that, when changed, puts "Mozilla Corporation" on the "Add or uninstall programs" control panel.

This diff file shows the change needed to solve the "bug". Just replace the string "Publisher" and, once the installer package is created, at the Control Panel it appears "Mozilla Corporation" as the Publisher of the application. My only doubt is if it should not be "Mozilla Foundation".
Thanks for the patch!

Alas, I'm not sure if the original issue still matters. Firefox does indeed show up as having just "Mozilla" in the Windows uninstall control panel, but Firefox no longer has an EULA to be consistent with. I'm not sure of the importance of this field (will changing have risk?). I sorta prefer just "Mozilla" as being less wordy. OTOH, all the other entries here seem to be using their stuffy legal names... "Microsoft Corporation", "Apple Inc.", "Google Inc.", "Adobe Systems Incorporated", etc.

Bouncing over to Rob Strong to consider.

Nice to see someone else interested in the installer, though. We can find some other work for you if you're interested. ;-)
Component: General → Installer
QA Contact: general → installer
Attachment #539227 - Flags: review? → review?(robert.bugzilla)
In fact, I tried to guess what should be the correct name, as all the "legal" terms from the site Mozilla.org mentions both Mozilla Foundation and Mozilla Corporation. I am not very into these terms, but believe that are real denominations inside de structure of the organization. Anyway, it served to me to get into the project. In fact, I remember some time ago, the publisher info was sometimes "Mozilla" and sometimes "Mozilla Corporation".

I will try to participate at the project, if there is something I could do (I know there is some work to do). I browse through the buglist base but many seemed a little complicated to me. Well, here I will be, if you need anyone :-).
This should probably actually use "${CompanyName}" so that's it's appropriately branding-dependent, but as with dolske I'm not sure whether there are potential downsides to having it vary between nightly/release builds (or whether there are risks to having it change at all, even just from one version to the next).
(In reply to comment #10)

> I will try to participate at the project, if there is something I could do
> (I know there is some work to do). I browse through the buglist base but
> many seemed a little complicated to me.

Take a look at bugs marked with "[good first bug]" in the whiteboard, here's a list... http://bit.ly/m2zINW Also, the IRC channel #introduction on irc://irc.mozilla.org is a good place to get started and get help. :)
Comment on attachment 539227 [details] [diff] [review]
File that, when changed, puts "Mozilla Corporation" on the "Add or uninstall programs" control panel.

If this is changed it will likely need to be different for nightly vs. other builds... I'm checking with legal
(In reply to comment #13)
> If this is changed it will likely need to be different for nightly vs. other
> builds... I'm checking with legal

In last patch I made I followed Comment #11, replacing the hardcoded name by $(CompanyName). However, before sending it, I am using Nightly repository. Should it be better to use Aurora or Mozilla20 repo?
Just heard back from Gerv and the current plan is to minimize the difference between Mozilla Foundation and Mozilla Corporation by using Mozilla. I think this bug is wontfix and a new bug should be filed to make all the other cases such as places we use Mozilla Foundation / Corporation and urls consistent after a plan is finalized.

email from Gerv:

The "One Mozilla" strategy says that we should be minimising the
difference between the Foundation and the Corporation in our public face
as much as possible. So ideally, all the certificates would just say
"Mozilla". If that's not possible for legal reasons (e.g. if the name is
in a certificate, and we can't get a code-signing cert for "Mozilla"),
then I think they should all say "Mozilla Foundation", which is the
parent of the Corporation, and hints at our non-profit status, which is
something we want to emphasize.

I certainly want to avoid the idea that the Foundation ships buggy,
unstable software and the Corporation ships the grown-up real deal. 

As for websites, I believe there is a plan afoot to merge mozilla.org
and mozilla.com. David can tell us more about that, and perhaps suggest
appropriate URLs for the builds.
Another email from David Boswell regarding this

That is right -- the www.mozilla.com site (and all public sites on the mozilla.com domain) are transitioning over to mozilla.org soon.  The www.mozilla.com site will live at www.mozilla.org/firefox, for instance.

As Gerv says, the reason we're doing this is because we don't think it's useful to use our organizational structure as a way to present information about what Mozilla does.

Unless there's a good reason, using just Mozilla and pointing to www.mozilla.org is the way to go instead of referencing either the Foundation or Corporation.
Where does the URL come into play? I thought we were just talking about a company name.

No matter what we want the value to be, it should probably be branding dependent, assuming that that doesn't introduce issues (I still don't really know how or for what purpose exactly this string is used).
It came into play if we were going to go with Mozilla Foundation (mozilla.org) and Mozilla Corporation (mozilla.com) which we are not going to do now. It is still in play (though for a different bug) because we have mozilla.com in some cases and mozilla.org in others which are to be changed to mozilla.org.
This string just appears in the "Uninstall a program" window on the field "Publisher". Don't know if you use Windows, but when you try to uninstall any program the way to go (the official and recommended by Microsoft) is going to this "repository" or list of programs usable on the installation. On this list it appears the name of the application, along it aproximate size, date of installation and the publisher.

The fact is that many other programs show the legal entity that developed the program. But, in the case of Firefox, "Mozilla" it is shown. There is no problem with this string, just that it appears to be less "corporative" or more "hippie" (from my view of point). Any application will follow running, whatever is the string shown here, even if it is blank.

In general: Finally, it seems that the final name is not very clear. As it is a mix of "what the legal entity should be shown" and if it should be shown the doamin used today or the new domain. So three or four options: blank, "Mozilla", "mozilla.org" or "mozilla.com". In my last patch (not sent), when using "$(CompanyName)" it is shown "mozilla.org" on the field. This is using the nightly build. Don't know if using the other ones.
btw: the mozilla.com and mozilla.org I referenced were in regards to the urls available in Add / Remove Programs (XP and below) or Programs and Features (Vista and above).

In relation to the publisher field, with this being the only bug I have ever seen wanting to change this since Firefox 2.0 I highly suspect having it be Mozilla is not a problem worth fixing and with legal and product marketing moving towards just using Mozilla to incorporate both the Foundation and Corporation I tend to think it is fine to just make sure it Mozilla for nightly, aurora, beta, and release.

Whatever the case, until there is a final word as to what these should be from legal and product marketing a patch for this will not be accepted in order to avoid churn.
Attachment #539227 - Flags: review?(robert.bugzilla)
Resolving -> wontfix since the current direction is to go with Mozilla. New bugs will be filed to update the other values after the changes needed are established.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
I think the hardcoding of "Mozilla" (as opposed to a branding-dependent string) is still a bug. I'm not sure what "new bugs" you're referring to - do they cover that problem?
(In reply to comment #22)
> I think the hardcoding of "Mozilla" (as opposed to a branding-dependent
> string) is still a bug. I'm not sure what "new bugs" you're referring to -
> do they cover that problem?

(In reply to comment #21)
> ... "New bugs will be filed"
So, the new bugs I am referring to will be filed. I am waiting on the final decision regarding the web site changes to file the bug(s) (probably take care of it all in the same bug).

I have no problem with making that value branding dependent but there have been no requests to make that branding dependent and the only bug I can think of regarding that is theoretical. I'll be sure that it is moved to branding after the decisions are finalized.
You need to log in before you can comment on or make changes to this bug.