When preferences are open, New>Message menu item doesn't open composition window

RESOLVED WORKSFORME

Status

Thunderbird
Preferences
--
minor
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Joseph Jackson, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/418.9.1 (KHTML, like Gecko) Safari/419.3
Build Identifier: version 2 beta 2 (20070116)

When the preferences window is opened and activated, the File>New>Message menu item fails to open a composition window. However, if another window is activated (brought to the front) while the preferences are still open, the New Message option works correctly.

Reproducible: Always

Steps to Reproduce:
1.Launch TB
2.Open Preferences window
3.Select File>New>Message, Message>New, or press Command-N
Actual Results:  
User feedback is given to indicate that the menu item is selected. For example, if the keyboard shortcut is used, the "Message" menu item flashes. However, no new message composition window appears.

Expected Results:  
One would expect a new message composition window to open and become active.

Comment 1

11 years ago
Joseph, did you see this problem in version 1.5?  Is it gone in 2.0 final? 
Version: unspecified → 2.0
(Reporter)

Comment 2

11 years ago
I've confirmed that the problem still exists in Thunderbird 2 RC1 and in Thunderbird 2.0.0.0 final. I'm relatively new to Thunderbird and don't have version 1.5 installed anywhere, so I can't say if the problem existed in that version.

Comment 3

11 years ago
There is no problem when Preferences window is made a background. 
(The main window of Tb is made the foremost side. )

The misunderstanding will disappear if changing into the main menu along Preferences window like the demand of Bug 232673. 

But to our regret, because Bug 232673 is WONTFIX, this might be WONTFIX. 

Comment 4

11 years ago
(In reply to comment #3)
>
> But to our regret, because Bug 232673 is WONTFIX, this might be WONTFIX. 

Asaf might be able to say. I don't know macs so I can't say whether these are the same issue.

Comment 5

10 years ago
The menubar now switches when the preferences pane is opened, so there is no File menu to select New from. -> WFM.  Feel free to reopen if you're still seeing this in a trunk nightly build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.