All users were logged out of Bugzilla on October 13th, 2018

gmail.com - Gmail spellchecking is broken due to usage of range.intersectsNode

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
12 years ago
4 years ago

People

(Reporter: Peter6, Assigned: uriber)

Tracking

({regression})

Details

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070206 Minefield/3.0a3pre ID:2007020700 [cairo]

repro:
Open FF
open Gmail and write a message with errors
press on [Check Spelling] just above the textfield

result: 
nothing happens

regressed:
month ago (before mid november 2006)

Comment 1

12 years ago
(In reply to comment #0)
> regressed:
> month ago (before mid november 2006)

before at least 20061118 according to bug 339616 

(Assignee)

Comment 2

12 years ago
Regression range is 2006-10-25-04 to 2006-10-26-05.

Perhaps bug 358073?
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 4

12 years ago
Yup. Gmail uses intersectsNode(), which was removed in bug 358073.
(Assignee)

Comment 5

12 years ago
http://developer.mozilla.org/en/docs/DOM:range.intersectsNode

So, Gmail should be fixed, meaning, I guess, that this is a Tech Evangelism bug. I'll see what I can do to "evangelize" :)
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: Gmail spellchecking is broken → gmail.com - Gmail spellchecking is broken due to usage of range.intersectsNode
Version: Trunk → unspecified
(Assignee)

Updated

12 years ago
Assignee: english-us → uriber
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

12 years ago
Fixed on the Gmail side (this might take time to propagate to non en-US Gmails).
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.