Firefox 2.0 crashes on when logging into Facebook and then immediately switching tabs

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Shiyue, Unassigned)

Tracking

2.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

On Windows Vista & Firefox, the browser crashes very often when logging into Facebook and then switching tabs right afterward.  Since I prefer not to wait when signing into the site, I have other tabs open and would like to switch to those while Facebook signs in.  But after clicking Login and then Control-TAB to switch to another tab, Firefox freezes and I would have to end-task the process.  If I wait for Facebook to sign in fully, and THEN switch to the other tab, Firefox does not crash.  This problem does NOT happen when I use Windows XP.

Reproducible: Sometimes

Steps to Reproduce:
1. Go to facebook.com in Firefox when using Windows Vista, make sure at least one other tab is open also.
2. Type in username and password for Facebook, and click login.
3. Immediately Control-TAB to the other tab while Facebook is signing in, Firefox will more often than not crash.
Actual Results:  
Windows Vista proved to be a disappointment so I am no longer using it.

Expected Results:  
The browser should be able to handle simultaneously Facebook signing in and user switching to another tab.
(Reporter)

Updated

12 years ago
OS: Other → Windows Vista
(Reporter)

Updated

12 years ago
OS: Windows Vista → Windows XP
Summary: Firefox crashes on Windows Vista when logging into Facebook and then immediately switching tabs → Firefox 2.0 crashes on when logging into Facebook and then immediately switching tabs
(Reporter)

Updated

12 years ago
OS: Windows XP → Windows Vista
WFM on Windows Vista using today's nightly, Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2pre) Gecko/20070208 BonEcho/2.0.0.2pre. Reporter: Do you have any extensions installed?

Comment 2

11 years ago
WFM, Firefox 2.0 on Windows Vista.

Updated

11 years ago
Version: unspecified → 2.0 Branch

Comment 3

11 years ago
Shiyue, does it work if you start Firefox in Safe Mode?
(it temporarily disables plugins and add-ons, this test will help us narrow
down the cause of the problem) --  See http://kb.mozillazine.org/Safe_Mode
(Reporter)

Comment 4

11 years ago
Seems like version 2.0.0.2 has fixed this problem, because I haven't experienced it since upgrading.

Comment 5

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
This problem only started when upgraded to 2.0.0.3
Tried this also in safe mode and the same happened.  Currently won't even let me log in without crashing regardless of other tabs open or only facebook open.

Comment 6

11 years ago
Michael, please file a separate bug for the crash and CC me.
(submit Talkback data if you can, http://kb.mozillazine.org/Quality_Feedback_Agent)

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.