Crash inside SendMenuOpening and [@ DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*)]

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
--
critical
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: Bill Lipa, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1




Date/Time:      2007-02-08 10:08:52.885 -0800
OS Version:     10.4.8 (Build 8L2127)
Report Version: 4

Command: firefox-bin
Path:    /Applications/Firefox.app/Contents/MacOS/firefox-bin
Parent:  WindowServer [245]

Version: 2.0.0.1 (2.0.0.1)

PID:    292
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000291

Thread 0 Crashed:
0   libobjc.A.dylib           	0x90a55398 objc_msgSend + 40
1   com.apple.HIToolbox       	0x92e6b7b4 SendMenuOpening(MenuSelectData*, MenuData*, double, unsigned long, __CFDictionary*, unsigned char, unsigned char*) + 322
2   com.apple.HIToolbox       	0x92e6b353 DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char*) + 209
3   com.apple.HIToolbox       	0x92e6b124 MenuChanged(MenuSelectData*) + 218
4   com.apple.HIToolbox       	0x92e6a3ca TrackMenuCommon(MenuSelectData&, unsigned char*) + 700
5   com.apple.HIToolbox       	0x92e68362 MenuSelectCore(MenuData*, Point, double, unsigned long, OpaqueMenuRef**, unsigned short*) + 224
6   com.apple.HIToolbox       	0x92e67f26 MenuSelect + 100
7   com.apple.HIToolbox       	0x92e67e84 StandardMenuBarEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 104
8   com.apple.HIToolbox       	0x92dc886b DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
9   com.apple.HIToolbox       	0x92dc7f10 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
10  com.apple.HIToolbox       	0x92dcf1f0 SendEventToEventTarget + 56
11  com.apple.HIToolbox       	0x92dcfc0d ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2587
12  com.apple.HIToolbox       	0x92dc8c22 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2044
13  com.apple.HIToolbox       	0x92dc7f10 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
14  com.apple.HIToolbox       	0x92dcf1f0 SendEventToEventTarget + 56
15  com.apple.HIToolbox       	0x92e130c7 ToolboxEventDispatcher + 81
16  com.apple.HIToolbox       	0x92e11adf RunApplicationEventLoop + 165
17  org.mozilla.firefox       	0x002405bf nsAppShell::Run() + 39
18  org.mozilla.firefox       	0x002d8be2 nsAppStartup::Run() + 50
19  org.mozilla.firefox       	0x00005e59 XRE_main + 5539
20  org.mozilla.firefox       	0x00002bb8 main + 32
21  org.mozilla.firefox       	0x00002b3e start + 270
22  org.mozilla.firefox       	0x00002a59 start + 41


Reproducible: Couldn't Reproduce

Comment 1

10 years ago
Confirming crash on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031404 Minefield/3.0b5pre

My STR was: crashed while on AMO surfing around for extensions. got there via Addons Manager 

Crash Stack: http://crash-stats.mozilla.com/report/index/7bafb8e3-f207-11dc-9527-001a4bd43e5c

Frame  	Signature  	Source
0 	DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*) 	
1 	MenuChanged(MenuSelectData*, unsigned char, unsigned char) 	
2 	TrackMenuCommon(MenuSelectData&, unsigned char*) 	
3 	MenuSelectCore(MenuData*, Point, double, unsigned long, OpaqueMenuRef**, unsigned short*) 	
4 	_HandleMenuSelection2 	
5 	_HandleMenuSelection 	
6 	_NSHandleCarbonMenuEvent 	
7 	_DPSNextEvent 	
8 	-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	
9 	-[NSApplication run] 	
10 	nsAppShell::Run() 	mozilla/widget/src/cocoa/nsAppShell.mm:587
11 	nsAppStartup::Run() 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:181
12 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3154
13 	main 	mozilla/browser/app/nsBrowserApp.cpp:158
14 	start 	crt.c:272 

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crash inside SendMenuOpening → Crash inside SendMenuOpening and @[DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*)]
Note that one of these crashes was on the branch (and therefore Widget:Mac) and the other is trunk (but ultimately both crashes are in Apple code).
Version: 1.8 Branch → Trunk
I hit this while loading a large page.
Signature: DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*)
http://crash-stats.mozilla.com/report/index/dae60540-04ac-11dd-85a5-001cc45a2c28

Comment 4

10 years ago
The crash is happening deep on Carbon code and only in Mac OS X version 10.5.2, so I'd say it's a bug in Apple's code. I looked around and couldn't really find anywhere to report such bugs, though.

Updated

9 years ago
Assignee: joshmoz → nobody

Comment 5

9 years ago
WFM - very few matching reports in crash-stats, vague yes common STR.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char, unsigned char*)]
You need to log in before you can comment on or make changes to this bug.