Last Comment Bug 369776 - SpreadFirefox download counter RSS feeds does not update
: SpreadFirefox download counter RSS feeds does not update
Status: RESOLVED FIXED
:
Product: mozilla.org Graveyard
Classification: Graveyard
Component: Server Operations (show other bugs)
: other
: All All
: -- major with 1 vote (vote)
: ---
Assigned To: Jeremy Orem [:oremj]
: Justin Fitzhugh
Mentors:
http://feeds.spreadfirefox.com/downlo...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-08 12:58 PST by Asbjørn Sloth Tønnesen
Modified: 2015-03-12 08:17 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Asbjørn Sloth Tønnesen 2007-02-08 12:58:08 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-2)
Build Identifier: 

The bug is about both feeds:
http://feeds.spreadfirefox.com/downloads/firefox.xml
http://feeds.spreadfirefox.com/downloads/thunderbird.xml

Both feeds publish timestamp is Thu, 14 Dec 2006 19:03:01 -0800

The result of these missing updates can be seen at my sites:
http://ff.asbjorn.it/
http://tb.asbjorn.it/

This is the same problem as bug #364097

Reproducible: Always

Fast way to reproduce:
1. Load the feed
2. Notice the pubDate in the feed

Actual results:  
pubDate is Thu, 14 Dec 2006 19:03:01 -0800

Expected results:
pubDate should only be seconds old.


Reproducible: Always

Steps to Reproduce:
1. Load the feed
2. Notice the pubDate in the feed
Actual Results:  
<pubDate> is Thu, 08 Feb 2007 01:15:01 -0800

Expected Results:  
pubDate should only be seconds old.
Comment 1 Jeremy Orem [:oremj] 2007-02-09 11:28:23 PST
The xml files are cached, so the pubDate will hardly ever be only seconds old.  We could lower the cache time, but it looks like it is updating.

Where did you find the Dec 2006 timestamp or is that just from the other bug?
Comment 2 Asbjørn Sloth Tønnesen 2007-02-09 14:58:45 PST
1) Well, maybe not seconds any longer, it has been in the past, but neither the pubDate nor the count has changed since Thu, 08 Feb 2007 01:15:01 PST. I have a crontab, for each of the feeds, running every 5 minutes which which alerts be when the count haven't changed in 15 minutes (These alerts are flooding my mailbox, maybe I should add a logging mechanism so I only get one mail an hour, instead of 24). Currently I will guess the Firefox counter is just above 299m, which means it has been down for about 1 million downloads time. We shouldn't miss the 300 million milestone.

2) That is from last time. I was a little to quick there.
Comment 3 Jeremy Orem [:oremj] 2007-02-11 01:30:02 PST
Ah, looks like this was actually a problem.  Last week that cron job was disabled.  I just renabled and everything looks great.  The download count right now is 299568960, this should show up in the feed soon.

Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.