crash [@ libflashplayer.so + 0xd07bc] at mouseover

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070207 BonEcho/2.0.0.2pre
Build Identifier: "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070207 BonEcho/2.0.0.2pre" - Build ID: 2007020704

Browsing http://devart.maureenwinter.de/embed.html

The main object in that page is a large animated image. Crash TB29144314G happened while hovering the mouse over that image.


Reproducible: Didn't try

Actual Results:  
crash

Expected Results:  
no crash

Additional info:

Crash happened 9 levels deep in libflashplayer.so which is the Shockwave Flash plugin for Linux, version 7.0 r69

The reason I opened a new bug is not that I didn't find any existing bug, but that I found too many and didn't know which one to use. Here are a few (those marked "<= duplicate?" have descriptions most similar to what happened to me, but they're "RESOLVED"):
bug 304370 (Core/Plug-ins/Trunk/PC/Linux) NEW  ---- (crash)
bug 329299 (Core/Printing/1.8/PC/XP) VERI FIXE (relnote,verified1.8.0.9,verified1.8.1.1)
bug 347266 (Core/Plug-ins/Trunk/PC/XP) NEW  ---- (crash,regression,testcase)
bug 350585 (Core/Printing/1.8/PC/XP) RESO DUPL (crash) of bug 329299
bug 353014 (Fx/General/Fx2.0/PC/Linux) NEW  ---- (crash)
bug 353507 (Core/Plug-ins/1.8/All/All) VERI INVA (crash) <= duplicate?
bug 356191 (Core/Plug-ins/Trunk/PC/XP) UNCO ---- (crash)
bug 357735 (Fx/General/Fx2.0/PC/Linux) VERI DUPL (crash) of bug 304370
bug 357745 (Core/Plug-ins/Trunk/PC/XP) NEW  ---- () [DUPEME?]
bug 359827 (Fx/General/unspec/PC/Linux) RESO WORK (crash) <= duplicate?
bug 366817 (Core/Plug-ins/1.8/PC/XP) UNCO ---- ()

Here comes the Talkback report:
Incident ID: 29144314
Stack Signature	libflashplayer.so + 0xd07bc (0x46d997bc) b73c832b
Product ID	Firefox2
Build ID	2007020704
Trigger Time	2007-02-08 11:27:41.0
Platform	LinuxIntel
Operating System	Linux 2.6.11.4-21.15-default
Module	libflashplayer.so + (000d07bc)
URL visited	it's gone now
User Comments	
Since Last Crash	5 sec
Total Uptime	5 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libflashplayer.so + 0xd07bc (0x46d997bc)
libflashplayer.so + 0xd1702 (0x46d9a702)
libflashplayer.so + 0xd3093 (0x46d9c093)
libflashplayer.so + 0xd2e2f (0x46d9be2f)
libflashplayer.so + 0xd2e2f (0x46d9be2f)
libflashplayer.so + 0xb64e1 (0x46d7f4e1)
libflashplayer.so + 0xeec6d (0x46db7c6d)
libflashplayer.so + 0xef991 (0x46db8991)
libflashplayer.so + 0x1884db (0x46e514db)
libXt.so.6 + 0x1ba85 (0x40923a85)
libXt.so.6 + 0x1bde2 (0x40923de2)
libXt.so.6 + 0x1ae5f (0x40922e5f)
libXt.so.6 + 0x28a18 (0x40930a18)
xt_event_dispatch()  [mozilla/widget/src/gtkxtbin/gtk2xtbin.c, line 175]
libglib-2.0.so.0 + 0x23967 (0x405ea967)
libglib-2.0.so.0 + 0x25ce2 (0x405ecce2)
libglib-2.0.so.0 + 0x26cf7 (0x405edcf7)
libgtk-x11-2.0.so.0 + 0x116be3 (0x402eabe3)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2693]
main()  [mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x14e80 (0x40a60e80)
Keywords: crash
Version: Trunk → 1.8 Branch
This seems to be a crash caused by the flash plughin and can't be fixed in Seamonkey/Firefox. A crashing plugin will always crash Gecko itself.

I don't know the current flash version for Linux but could it be that there is a newer version of flash available ?
(you can fix this only with an updated flash plugin)
 

Comment 2

12 years ago
flash v7 for linux is now way outdated.
current version is Flash 9.0 r31

does it solve your crash?

Comment 3

12 years ago
in win xp this didin't charch at all
using Shockwave Flash 9.0 r28

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070306 BonEcho/2.0.0.3pre

---->>>  WORKSFORME
(In reply to comment #2)
> flash v7 for linux is now way outdated.
> current version is Flash 9.0 r31
> 
> does it solve your crash?
> 

Hm. More often than not, my crashes are intermittent, depending on such intangible factors as processor load.

ATM I can't reproduce this crash (maybe tomorrow or next week?) Currently the version shown in about:plugins is 9.0 r31

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3pre) Gecko/20070306 BonEcho/2.0.0.3pre
- Build ID: 2007030604

Comment 5

11 years ago
(In reply to comment #4)
> (In reply to comment #2)
> > flash v7 for linux is now way outdated.
> > current version is Flash 9.0 r31
> > 
> > does it solve your crash?
> > 
> 
> Hm. More often than not, my crashes are intermittent, 

and now?
Hm. Loading the URL in a new tab and hovering the mouse over it didn't crash Firefox *this time*. I'm not a particularly assiduous Flash user anyway. Can you check the crash statistics for recent Talkback or Breakpad events similar to this? (I'm not sure what to search for and how to make sense of the results). I won't oppose marking this WFM but I'll keep Talkback or Breakpad enabled on all my Mozilla-products builds -- and use them. What do you think?

Comment 7

10 years ago
It appears this bug was entered against Flash Player 7.  We don't see it happening with Flash Player 9 or the recent Flash Player 10 betas.  Could someone try to repro with these versions?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080909000830 SeaMonkey/2.0a1pre
Shockwave Flash 9.0 r124
no crash, however this is a Trunk build

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18pre) Gecko/20080909 BonEcho/2.0.0.18pre
 - Build ID: 2008090903
Shockwave Flash 9.0 r124
no crash

Warning: This isn't a page I browse frequently.

It looks like there were no recent complaints about this problem. I'm tentatively resolving this WORKSFORME, feel free to REOPEN (with due details) if it reappears.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: 1.8 Branch → unspecified
(Assignee)

Updated

7 years ago
Crash Signature: [@ libflashplayer.so + 0xd07bc]
You need to log in before you can comment on or make changes to this bug.