Last Comment Bug 369830 - [oc] Occitan: Firefox
: [oc] Occitan: Firefox
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: Future
Assigned To: Localization Registration Bugs
:
Mentors:
Depends on:
Blocks: 367341
  Show dependency treegraph
 
Reported: 2007-02-09 01:52 PST by Yannig MARCHEGAY
Modified: 2008-11-25 01:32 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Xulrunner localization (82.54 KB, application/x-xpinstall)
2008-06-25 08:55 PDT, Yannig MARCHEGAY
no flags Details
Firefox localization (37.46 KB, application/x-xpinstall)
2008-06-25 08:55 PDT, Yannig MARCHEGAY
no flags Details
Occitan localization. (953 bytes, application/x-bzip)
2008-06-25 09:54 PDT, Yannig MARCHEGAY
l10n: review-
Details
Occitan xpi (126.78 KB, application/x-xpinstall)
2008-07-26 04:30 PDT, Yannig MARCHEGAY
no flags Details
CVS tree structure for oc locale + results.log file (99.10 KB, application/octet-stream)
2008-07-30 19:19 PDT, Cédric Corazza
no flags Details
Firefox Occitan translation (122.96 KB, application/x-gzip)
2008-08-11 08:30 PDT, Yannig MARCHEGAY
l10n: review+
Details

Description Yannig MARCHEGAY 2007-02-09 01:52:31 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: 

Hello,

I'm the Occitan translation coordinator for Ubuntu (and others) and I'd like to register a team for translating Firefox (and others products afterwards) into Occitan.
Occitan is a Romance language spoken in Occitania (i.e. Southern France, Monaco and some valleys of Italy and Spain). All of its subdivisions are generally mutually intelligible but different enough to deserve separate translations. Right now, we are translating in Lengadocian (main subdivision) but some translators may be interested one day in translating in other subdivisions.
The ISO code (639-2) is "oci" now but an ISO code (639-3) make it possible to separate the different Occitans (lnc for Lengadocian and gsc for Gascon for example). Would it be possible to use it so as to make better work ?

Regards,
Yannig

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Axel Hecht [:Pike] 2007-02-09 02:54:04 PST
Pascal, I'd like to see your comments on the Occitans locales, too.

There is this one paragraph on http://en.wikipedia.org/wiki/Occitan that gives me the munchies.
Comment 2 Yannig MARCHEGAY 2007-02-09 04:18:05 PST
What would you like to know? I may be able to help.
Comment 3 Axel Hecht [:Pike] 2007-02-09 05:27:12 PST
I chatted a bit with Pascal on irc, to affirm that we're talking about a language here more than a regional politics thing.

We should use the /1 locale code oc for this. We're far from having the infrastructure set up to do variants of languages efficient enough so that we can actually go out and register locales in abundance.

Confirming. Please add information about your team to http://wiki.mozilla.org/L10n:Teams:oc, in a similar way as they are on http://wiki.mozilla.org/L10n:Localization_Teams.

Check out http://developer.mozilla.org/en/docs/Create_a_new_localization for the next steps in the registration process, which would be a localization for review.
Comment 4 Yannig MARCHEGAY 2007-02-09 05:32:00 PST
Thanks a lot. Should I add the information in English or can I do it in Occitan?
I'm already translating Firefox (helped by the French l10n team for technical problems) so I'll just have to have a CVS account and commit the translations soon.
Comment 5 Axel Hecht [:Pike] 2007-02-09 05:38:20 PST
The information should be in English, maybe add the native language name in there, too.

I'm happy to see the French team helping out. I'll still do a technical review of your localization, though. That's good, because I'll be the one vouching for your CVS account, too. I'd be happy to see review comments from your French helpers, too, of course.
Comment 6 Yannig MARCHEGAY 2007-02-09 05:47:41 PST
Occitan is the same in English and in Occitan, fine :o)
For now, I'm only translating the files under fr.jar, seeing my Firefox half-translated by replacing those files in fr.jar

I'm still unable to use SVN or CVS (except for checking) for I don't find simple documentation about it (check, commit).
Comment 7 javierTorres 2007-02-12 08:04:59 PST
I speak spanish and my english is very bad.
Occitan (oc-FR), is not exactly correct.
Exist a dialect (Aranese- Gascon dera Val d'Aran) in Spain, so i need te specification of aranese (oc-ES) in this teem or in other teem to translate the firefox.
more info:
http://en.wikipedia.org/wiki/Aranese_language
http://wwwa.urv.net/centres/Departaments/dfag/gallego.html
http://www.proel.org/lenguas/aranes.html
Comment 8 Yannig MARCHEGAY 2007-02-12 08:14:25 PST
That's one reason why I asked for a 639-3 ISO code, it would be more accurate.
Comment 9 Toni Hermoso Pulido 2007-02-12 08:57:22 PST
It's good news to have people working on Occitan versions. I do not know if this may help but, look up at this document:
http://wiki.mozilla.org/L10n:Simple_locale_name

I read that some people have considered the Lengadocian variety as somewhat a standard variety mostly because it is the most similar to the classical variety. However, I could understand using plain «oc» for Lengadocian might be offensive to other Occitan speakers. 
I do not know how likely it is to have other varieties in the future (ex. Provençal and Lemosin). AFAIK, the most important and also, maybe apart varieties, are actually Lengadocian and Gascon.

As much as you can, I would suggest you to interchange opinions and share the most code you can, terminology, etc. This will help and make easier your work, especially considering there are still few Occitan translators who may contribute in such efforts. If you are interested, I would contact you apart.

Tà dauant!
 
Comment 10 javierTorres 2007-02-12 10:36:10 PST
Ok, very good.
But is very dificult for me to undestand your comments in english.
I prefer to speak spanish,french,catan or occitan.
You can contact with me in www.occitans.com
Comment 11 Axel Hecht [:Pike] 2007-02-12 10:47:19 PST
I honestly don't think that either -FR nor -ES will make it anywhere, as I don't think that it's going to do much good to use region codes there.

How noticeable would the differences between Lengadocian and Gascon in a browser environment, though?
Comment 12 Yannig MARCHEGAY 2007-02-12 10:52:44 PST
Very simple : Lengadocian and Gascon do not understand each other...
Comment 13 javierTorres 2007-02-14 03:06:35 PST
I think gsc is correct, but i prefer to use gsc-ES. You can choose at your own criteria
Comment 14 Gervase Markham [:gerv] 2007-09-19 02:50:37 PDT
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
Comment 15 Yannig MARCHEGAY 2007-09-19 04:01:27 PDT
I'm still interested for translating Firefox and Thunderbird into Occitan (Lengadocian).
Comment 16 javierTorres 2007-09-19 04:13:48 PDT
	
The correct codificiación for lengadociano is lnc ISO/DIS 639-3, not gsc.

Not if you know that an orthographic corrector in lengadociano for oppenoffice exists. To the equal one it serves to you as aid.
Comment 17 Yannig MARCHEGAY 2007-09-19 04:17:03 PDT
Thanks for the information about lnc code.
I know about the Lengadocian OpenOffice dictionary, it's been installed on my computer for months :-)
Comment 18 Gervase Markham [:gerv] 2007-09-24 14:42:07 PDT
Yannig: great :-) You need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, which registers you as the team for that language. Then, follow the instructions on the wiki to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv
Comment 19 Yannig MARCHEGAY 2007-09-26 03:10:04 PDT
yannig@yannig-portable:~/occitan/firefox/build$ make -C browser/locales langpack-oci-X-dudemake: *** browser/locales: No such file or directory.  Stop.
yannig@yannig-portable:~/occitan/firefox/build$ ls
confdefs.h  config.cache  config.log
Comment 20 Yannig MARCHEGAY 2007-09-26 13:50:25 PDT
Oooops, bad shortcut: I was trying to do what http://developer.mozilla.org/en/docs/Creating_en-X-dude#Create_a_language_pack indicates and the problem is with the "make -C browser/locales" line.
Comment 21 Gervase Markham [:gerv] 2007-09-27 13:56:36 PDT
Yannig: the newsgroup news://news.mozilla.org/mozilla.dev.l10n is probably the best place to ask questions.

Gerv
Comment 22 Toni Hermoso Pulido 2007-10-01 08:03:43 PDT
I will be assisting Yanning to follow the necessary steps.
Comment 23 Axel Hecht [:Pike] 2007-10-04 05:27:42 PDT
According to http://www.sil.org/iso639-3/documentation.asp?id=gsc and http://www.sil.org/iso639-3/documentation.asp?id=lnc, both of these are retired in favour of oci, which is equivalent to oc.

I see a good reason to specify the dialect of Occitan here, independent of FR vs ES, so I suggest we use something like oc-languedocien or oc-X-..., don't know which right now. That has the English name of the dialect as variant, I need to figure out if we need to seperate that with a -X or must not. RFC 4646 is long :-(. It does say 'oc' for sure, though.
Comment 24 Gervase Markham [:gerv] 2008-01-30 10:15:04 PST
Yannig, Toni: how are things going? Has there been any further progress?

Gerv
Comment 25 Yannig MARCHEGAY 2008-01-30 10:20:21 PST
Well, I must confess I'm rather discouraged by the fact I cannot see my ongoing translations applied on my computer so I'm more working on GNOME and KDE these months :-(
I'll go back to Firefox translations next week.
Comment 26 Gervase Markham [:gerv] 2008-02-06 02:05:44 PST
Yannig: I don't quite understand what you mean. Are you having technical problems testing your translation?

Gerv
Comment 27 Yannig MARCHEGAY 2008-02-06 02:43:39 PST
No technical problem, it's just less easy than other ways to translate. I'll have to get used...
Comment 28 Yannig MARCHEGAY 2008-06-22 07:02:43 PDT
No way to know how much it is translated (in %) but any "visible" texts in a "normal" Firefox use is now in Occitan. Of course, I go on translating both Firefox and Xulrunner but can I now make it available for everybody?
Comment 29 Axel Hecht [:Pike] 2008-06-25 08:52:23 PDT
Please attach the sources here for review, see http://wiki.mozilla.org/L10n:Becoming_an_Official_Localization#Preparation for details.
Comment 30 Yannig MARCHEGAY 2008-06-25 08:55:11 PDT
Created attachment 326710 [details]
Xulrunner localization
Comment 31 Yannig MARCHEGAY 2008-06-25 08:55:29 PDT
Created attachment 326711 [details]
Firefox localization
Comment 32 Yannig MARCHEGAY 2008-06-25 08:56:11 PDT
Here are the attachments. I had a look at http://wiki.mozilla.org/L10n:Becoming_an_Official_Localization#Preparation but no way to find how to merge the two files.
Comment 33 Axel Hecht [:Pike] 2008-06-25 08:58:55 PDT
Comment on attachment 326711 [details]
Firefox localization

Please look at Cedric's tool to convert language packs to sources, http://pagesperso-orange.fr/cedric.corazza.net/html/langpack2cvstree.html.

There should only be one source for both xulrunner and Firefox, as one is a subset of the other.

The tool will point out things left to do, too, as the language pack only contains parts of the complete localization.
Comment 34 Yannig MARCHEGAY 2008-06-25 09:45:53 PDT
The problem is that I have firefox-oc.jar and xulrunner-oc.jar. I used langpack2cvstree.sh with firefox-oc.jar and I completed the missing files but nothing is done with xulrunner-oc.jar
Comment 35 Axel Hecht [:Pike] 2008-06-25 09:50:18 PDT
There really shouldn't be anything in xulrunner-oc.jar that isn't in firefox-oc.jar. We don't really have a good concept for localizing xulrunner anyway, so that doesn't matter that much for the process here.
Comment 36 Yannig MARCHEGAY 2008-06-25 09:54:27 PDT
Created attachment 326721 [details]
Occitan localization.

I followed all the instructions from your two links and here it is.
Comment 37 Yannig MARCHEGAY 2008-07-11 12:53:06 PDT
Anything new?
Comment 38 Axel Hecht [:Pike] 2008-07-26 03:08:24 PDT
Comment on attachment 326721 [details]
Occitan localization.

Sorry for the lag. Next time, please set the review flag on the attachment to '?' and enter my bugmail as requestee, that way it ends up on my queue.

r- on this attachment, it doesn't have any files in it, just the directories :-?
Comment 39 Yannig MARCHEGAY 2008-07-26 04:30:34 PDT
Created attachment 331410 [details]
Occitan xpi

Sorry. Here is an xpi with the whole localization.
I'm trying to add it on addons.mozilla.org but I made a mistake (version 3.0 instead of 1.0) and I cannot modify it nor delete the module in order to create a proper module.
Comment 40 Yannig MARCHEGAY 2008-07-27 07:03:48 PDT
The addon is now available at https://addons.mozilla.org/fr/firefox/addon/7854
Comment 41 Axel Hecht [:Pike] 2008-07-27 23:50:47 PDT
Comment on attachment 331410 [details]
Occitan xpi

As I mentioned in comment 29 and 33, I need a source to do the technical review, a language pack is not good enough. Among other things, I need to make sure that you can work on the data that we use to create our builds, that's why I'm picky here.
Comment 42 Yannig MARCHEGAY 2008-07-28 01:06:40 PDT
Honnestly, I've translated via two po files I downloaded from Launchpad. One was for Firefox, the other for Xulrunner. They have a bash script to make xpi files from them and it seems I cannot use them with langpack2cvstree.sh
I began translating .dtd files but I found easier to go on with that system. I guess these two jar files wouldn't be enough?
Comment 43 Cédric Corazza 2008-07-30 19:19:04 PDT
Created attachment 331818 [details]
CVS tree structure for oc locale + results.log file

Yannig, here's the tar.gz file containing oc locale cvs tree structure based on the xpi you attached.
Included, the results.log file which indicates what files or strings are missing or obsolete. Feel free to ping me on IRC if you got problem to interpret this log file.
Comment 44 Yannig MARCHEGAY 2008-08-06 13:21:28 PDT
Great, thanks a lot ! I hope it will be enough :-)
Comment 45 Yannig MARCHEGAY 2008-08-11 08:30:15 PDT
Created attachment 333232 [details]
Firefox Occitan translation
Comment 46 Axel Hecht [:Pike] 2008-09-08 03:33:32 PDT
Comment on attachment 333232 [details]
Firefox Occitan translation

r=me, I'm doing a few local changes before comiting this to cvs. I'll file the follow-up bugs now to get going.
Comment 47 Yannig MARCHEGAY 2008-09-08 12:14:32 PDT
Thanks a lot, it's great to see things moving.
Comment 48 Axel Hecht [:Pike] 2008-09-10 14:31:53 PDT
Marking FIXED, thanks for your patience. Further updates will happen in the follow up bugs, depending on bug 454159 for fx3.

Note You need to log in before you can comment on or make changes to this bug.