Exporting items changes lastModifiedDate (and creationDate and stampTime)

RESOLVED DUPLICATE of bug 327930

Status

Calendar
Import and Export
--
major
RESOLVED DUPLICATE of bug 327930
11 years ago
11 years ago

People

(Reporter: Norbert Püschel, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a1) Gecko/20061006 Sunbird/0.3 XPCOMViewer/0.9.5

There is a very severe bug affecting Lightning & Sunbird 0.3 as well as current nightly build: Accessing Calendar Items (for example when exporting them to ics file will update the item timestamps creationDate, lastModifiedDate and stampTime)  to the current time! This makes them unusable for synchronisation purposes.

Reproducible: Always

Steps to Reproduce:
1.Export a calender to ics.
2.Wait a few seconds and export again.
3.Open both files in text editor and compare CREATED, LAST-MODIFIED and DTSTAMP 
Actual Results:  
all timestamps off all events are set to the current time

Expected Results:  
these timestamps should have meaningful values :-(

The error is apparently not in the export-routinge, but at the core of the system. I am just now programming a synchronisation extension and am calling calendar.getItems directly, which already returns items with bad timestamps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 327930
You need to log in before you can comment on or make changes to this bug.