Exception is thrown (Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)) when importing ics file created by Outlook with occuring meeting

RESOLVED DUPLICATE of bug 357252

Status

Calendar
Import and Export
RESOLVED DUPLICATE of bug 357252
11 years ago
11 years ago

People

(Reporter: Marcin Czeczko, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Thunderbird Mozilla/version 1.5.0.9 (20061207) + Lightning version 0.3 (build 2006100618)

When importing ics file created in MS Outlook into lightning it causes that following "Error getting calendar" message windows is displayed:
Unable to read from file:C:\Documents and Settings\user\Desktop\Part.ics

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE)[calIIcalComponent.startTime]" nsresult: "0x80004005 (NS_ERROR_FAILURE)"location:"JS frame ::
file:///C:/Documents%20and%20Settings/user/Application%20Data/Thunderbird/Profiles/3v9s11gr.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItemBase.js
:: anonymous :: line 514" data: no]

Used ICS file is as follows:
BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 10.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
BEGIN:STANDARD
DTSTART:20061029T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
TZOFFSETFROM:+0100
TZOFFSETTO:+0000
TZNAME:Standard Time
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:20060326T010000
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
TZOFFSETFROM:+0000
TZOFFSETTO:+0100
TZNAME:Daylight Savings Time
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
ATTENDEE;CN=Test;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:test@test.com
ORGANIZER:MAILTO:organizer@test.com
DTSTART;TZID="Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London":20070212T100000
DTEND;TZID="Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London":20070212T110000
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=MO;WKST=MO
LOCATION:Test location
TRANSP:OPAQUE
SEQUENCE:0
UID:040000008200E00074C5B7101A82E00800000000E0527C073E4CC7010000000000000000100
 0000078F700C4126622478CCAD75075FD1DAC
DTSTAMP:20070209T113250Z
DESCRIPTION:When: Occurs every Monday effective 12/02/2007 from 10:00 to
  11:00 (GMT) Greenwich Mean Time : Dublin\, Edinburgh\, Lisbon\,
  London.\nWhere: Test Location\n\n*~*~*~*~*~*~*~*~*~*\n\n Weekly
  Meeting…\n\nDetails:\n1. Call to: +11 11
  1111111\n2. Enter: 111\n3. Enter room number: 111\n
SUMMARY:Weekly Meeting
PRIORITY:5
CLASS:PUBLIC
BEGIN:VALARM
TRIGGER:-PT15M
ACTION:DISPLAY
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR

Reproducible: Always

Steps to Reproduce:
1. Choose Calendar->Import menu item
2. Select ics file descibed in bug and click OK

Actual Results:  
Exception is displayed as described in bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357252
You need to log in before you can comment on or make changes to this bug.