keep the history of visited pages cached for a certain time.

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
11 years ago
7 years ago

People

(Reporter: Elmar Stellnberger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.1) Gecko/20061217 SUSE/2.0.0.1-25.1 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.1) Gecko/20061217 SUSE/2.0.0.1-25.1 Firefox/2.0.0.1

It is a nice and very good feature that FiFox can keep the pages visited in the last N days in its cache so that they can even be viewed offline via the history.

Reproducible: Always

Steps to Reproduce:
1.visit a daily changed page (like orf.at) every day
2.recall this page from the history of different days
3.
Actual Results:  
Since the URL keeps to be the same it will only be possible to view the latest occurence of a single page.
i.e.: When recalling the history content of a day in the past it will not show the original content but a newer one.

Expected Results:  
It should be possible to recall different versions of the same page from the cache by the history.
Extensions like ScrapBook https://addons.mozilla.org/firefox/427/ and Auto Save Document https://addons.mozilla.org/firefox/2704/ do this.
I think this is not a function that the average user needs.
this would require a big amount of space in a db, and worst performance... so i'm suggesting to mark this invalid and leave that to an extension

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
Whiteboard: wontfix?

Comment 3

7 years ago
I agree.
Yes, rethinking to it again, it's not something that a browser should do for all users, there are various web services that can do this, and shuld not be crazy for add-ons. But saving a full webpage locally, and doing this for all pages is not something most users need.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
You need to log in before you can comment on or make changes to this bug.