Crashes/hangs after new mail notification arrives, caused by Sky Pilot Classic Theme

RESOLVED DUPLICATE of bug 403414

Status

--
critical
RESOLVED DUPLICATE of bug 403414
12 years ago
9 years ago

People

(Reporter: yevg, Unassigned)

Tracking

({hang})

SeaMonkey 1.1 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

Just everytime new mail arrives, seamonkey crasjes/hangs.


Reproducible: Always

Steps to Reproduce:
1.check new mail
if new mail exists - crash/hang

Actual Results:  
if new mail exists - crash/hang

Expected Results:  
nornal operation
Evgeny, can you reproduce this with a recent version of SeaMonkey?
(Reporter)

Comment 2

11 years ago
Hi,

Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.12) Gecko/20080209 SeaMonkey/1.1.8 is ok now.
Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

11 years ago
sorry, no, still the trouble. I was able to click on it and account with new mail was showed - however - still freezing the entire process
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 4

11 years ago
Yevgeny, can you check - message is base64 encoded ? And also is Seamonkey freezing or crashing?
(Reporter)

Comment 5

11 years ago
Seamonkey is freezing. message is plain text. seamonkey gets frozen immediately after notification disappears

Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.13) Gecko/20080402 SeaMonkey/1.1.9
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041601 SeaMonkey/2.0a1pre

I don't remember ever seeing this. Setting Version to Sm 1.1
Version: unspecified → SeaMonkey 1.1 Branch
Yevgeny,

Much more details are needed, like:

Does it happen on a specific account or any/all ?
Can you reproduce with a new/clean profile, no extension installed ?
Could it be related to antivirus/firewall/... ?

What happens during the hang ? CPU usage, memory increase, just frozen ?
Do you have any tool to "debug" the SeaMonkey process ?
(Reporter)

Comment 8

10 years ago
Fresh seamonkey profile tested without a trouble.

A profile with skypilot classic theme from https://www.projectit.com/ either makes seamonkey frozen or just terminate when new mail notification gets active. CPU usage is usual. I have gdb to debug but let me know how should I do that properly.

I understand that could be theme problem, but anyway seamonkey should not crash/hang imho
(In reply to comment #8)
> A profile with skypilot classic theme from https://www.projectit.com/ either

R.Invalid:
see (+/- duplicate) bug 403414 comment 4.

> anyway seamonkey should not crash/hang imho

I concur, but that's how it "works" for now :-(
Blocks: 403414
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → INVALID
Summary: crashes/hangs after new mail notification arrives → Crashes/hangs after new mail notification arrives, caused by Sky Pilot Classic Theme
(Reporter)

Comment 10

10 years ago
Hi,

I can't agree with resolved status of this bug. Seamonkey should respond after a bug in the theme.

I will change the severity from 'crash' to 'enhancement' then. Please remove a crash/freeze/hanging from expected behaviour of Seamonkey as a reaction on a bug in a theme.
Severity: critical → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 11

10 years ago
this hang still exists in Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.8.1.15) Gecko/20080629 SeaMonkey/1.1.10

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: search
Assignee: mail → nobody
QA Contact: search → message-display

Comment 12

9 years ago
not SM's fault
Severity: enhancement → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403414
You need to log in before you can comment on or make changes to this bug.