Doesn't jump to anchor tags within a table

RESOLVED DUPLICATE of bug 176449

Status

()

Core
HTML: Parser
--
enhancement
RESOLVED DUPLICATE of bug 176449
12 years ago
12 years ago

People

(Reporter: tylernt, Assigned: mrbkap)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

If you navigate to an URL with an anchor (index.html#anchor), and that anchor name is within a table, Firefox does not scroll to the anchor name. Rather, it scrolls to the top of the table containing the anchor name. Internet Explorer will scroll to the anchor name within the table as expected.

Reproducible: Always

Steps to Reproduce:
1. Navigate to a page that contains anchor names inside of a table
2. Click on an anchored link or type the anchor into the Address Bar

Actual Results:  
1. Firefox scrolls to the top of the table containing the anchor name

Expected Results:  
1. Firefox scrolls to the actual location of the anchor name within the table

Internet Explorer will scroll to the anchor name within the table as expected.

Comment 1

12 years ago
Created attachment 254572 [details]
testcase

Do you have a testcase?  This testcase works as expected.
(Reporter)

Comment 2

12 years ago
The test case is an internal page that I can't post publicly, but upon closer inspection it looks like an HTML error contributes to this issue. The code says [table][tr][a name=value]somedata[/td][td]moredata[/td][/tr][/table] so there is a missing [td] tag. I suppose the fact that IE handles the malformed HTML doesn't necessarily mean that Firefox should too.
Severity: normal → enhancement

Comment 3

12 years ago
Firefox's HTML parser pushes things that don't belong in tables outside of the table (except for forms, where it uses a crazy hack).
Assignee: nobody → mrbkap
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser
Version: unspecified → Trunk

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 176449
You need to log in before you can comment on or make changes to this bug.