bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

iMIP Toolbar does not appear in standalone message window

VERIFIED FIXED in Lightning 0.5

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Rich Renomeron, Assigned: cmtalbert)

Tracking

unspecified
Lightning 0.5

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: Lightning 0.3

The display of Outlook Meeting Requests/iMIP messages fixed by Bug 343049 only works on the message pane of the main Thunderbird window.  If you turn the message pane off and/or open the message in a separate window, the iMIP bar does not appear.  Since I don't use the message pane, this makes it difficult to deal with iMIP messages w/ Lightning.

Reproducible: Always

Steps to Reproduce:
1. Open a meeting request in a separate window
Actual Results:  
No iMIP bar appears

Expected Results:  
iMIP bar appears
(Assignee)

Comment 1

12 years ago
I can confirm this on Mac OS X with Thunderbird 2.0 b2 and Lightning 2007012205 (0.4a1).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

12 years ago
Created attachment 257797 [details] [diff] [review]
Refactors the imip-bar overlay

To fix this, we had to add the imip overlay as a separate XUL file so that it could also overlay messageWindow.xul.  As a result of now existing in the messageWindow.xul space, we lost the Cc and Ci const definitions, so I removed those from the imip-bar.js file.  

Since this is moving the same UI we use in the messagePane into the messageWindow, does it need UI review?
Assignee: nobody → ctalbert.moz
Status: NEW → ASSIGNED
Attachment #257797 - Flags: first-review?(lilmatt)
I don't think it needs ui-r.  It's the same UI, but just implemented in a different fashion.
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → Lightning 0.5
(Assignee)

Comment 4

12 years ago
Created attachment 257859 [details] [diff] [review]
Style nits and works around an alignment layout issue in thunderbird
Attachment #257797 - Attachment is obsolete: true
Attachment #257859 - Flags: first-review?(lilmatt)
Attachment #257797 - Flags: first-review?(lilmatt)
Comment on attachment 257859 [details] [diff] [review]
Style nits and works around an alignment layout issue in thunderbird


> /**
>- * iMIP notification bar
>- */
>+* iMIP notification bar
>+*/
> #imipNotificationImage {
>-    list-style-image: url("chrome://calendar/skin/cal-icon32.png");
>-    -moz-image-region: rect(0px, 32px, 32px, 0px);
>+list-style-image: url("chrome://calendar/skin/cal-icon32.png");
>+margin-right: 8px;
> }
> 
> #imipNotificationBar {
>-    border: 1px solid #87bbcc;
>-    -moz-border-radius: 7px;
>-    background-color: #baeeff;
>-    padding: 3px 6px 4px 6px;
>-    margin: 6px 6px 0px 6px;
>-    color: black;
>+background-color: #baeeff;
>+padding: 6px 8px;
>+color: black;
> }

Fix this indenting before checkin

r=lilmatt with that fixed.
Attachment #257859 - Flags: first-review?(lilmatt) → first-review+
(Assignee)

Comment 6

12 years ago
Checked in on branch and trunk --> Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Verified with Tb 2.0.0.5pre with Lightning 0.5 RC1 on Windows XP.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 380592

Updated

11 years ago
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
You need to log in before you can comment on or make changes to this bug.