While closing a window designed to print a page, all tabs and browser closed completely.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: circed, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070209 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070209 SeaMonkey/1.5a

I was browsing through the Dell web site and had two tabs open. I clicked on the page to read details of one of the products. I tried to print it and it hung. When I clicked the red X, all browser windows closed.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.Goto http://www.dell.com/content/topics/promo.aspx/promocompare?c=us&cs=19&l=en&s=dhs&~section=pri_desktops&~ck=anavml
2.Click on Notebooks and Save $370 on selected Inspiron Notebooks
3.Print the page, close the window using the red x instead of the close window button.
Actual Results:  
Window closed. Browser remained open.

Expected Results:  
Expected all windows to close as it did at first.

No other programs running.
Can you reproduce with SeaMonkey v2.0a1pre ?
Version: unspecified → Trunk
No reply yet to comment #1 => INCOMPLETE.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.10pre) Gecko/20100419 SeaMonkey/2.0.5pre - Build ID: 20100419001026

I often close the Print Preview by the top-right X, this doesn't close the browser.

If the reporter means that clicking the X button at top-right of the window containing (in one of its 1 or more tabs) the HTML page just printed (after using the Print button & dialog, maybe) then that's expected behaviour (and should be RESO INVA); but (unless disabled by pref) it should give a warning popup if 2 or more tabs are open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.