smtp dies if incoming POP or IMAP server goes down

RESOLVED INVALID

Status

Thunderbird
General
--
major
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: william drescher, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-07-01)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 1.5.0.9 (20061207)

May be related: I had a similar situation where a running fine Thunderbird (version 1.5.0.9 (20061207)) on WinXP SP2 suddenly stopped sending to any of three smtp mail servers.

It turned out that the problem was that one of 3 incoming servers (on account POP, one account IMAP) went down.  Thunderbird would keep downloading mail from the other server but would not send mail to any smtp server.

Even when the sever came back up, I still could not send.  Other computers running the same thunderbird version could send (they did not access the down server).
A restart of thunderbird did not help.
A warm XP reboot did not help.
A cold boot after a 30 sec delay did the trick, after the down server restarted.

It appears that thunderbird gets unhappy if an incoming mail server goes down.
The IMAP account on the down server does not use secure connections or authentication and the POP account does not either.


Reproducible: Always

Steps to Reproduce:
1.Have IMAP or POP server (unsure which) go down for > ~ 1 hour
2.
3.
Actual Results:  
Although other POP and IMAP accounts still will download mail/headers, Thunderbird will no longer send email.  I tried 3 different smtp servers.  The default smtp server is not the one that went down.


requires a cold reboot of the client to fix

Comment 1

12 years ago
I'd look elsewhere for the cause of the problem - the smtp server and the incoming servers are completely separate as far as Thunderbird is concerned.
(Reporter)

Comment 2

12 years ago
I would think so too, but the fact remains that, more than once, the smtp send problem develops when a POP or IMAP server goes does for a "long" period of time and it can only be fixed with a cold boot.

At least two users of our LAN have reported this problem, independently.
bill

Comment 3

12 years ago
If I'm understanding you correctly, if restarting thunderbird doesn't help, and a warm reboot of XP didn't help, that argues that something is going on outside of TB. How does the failing occur? Does it fail connecting to the SMTP server? Or do you get an error back from the SMTP server?
(Reporter)

Comment 4

12 years ago
The error message in TB is (paraphrased) Could not connect to the smtp server. Please check.....

I would suspect the TCP stack, but all other internet connections go through.

I am behind a Netgear FVS318 router/firewall, set to allow all outbound connections and a cable modem.

It would appear that whatever is getting munged requires a hardware restart.  This would agrue against it being TB, but it has happened on two separate computers running TB, on different days with different POP servers failing, so that argues that TB is involved somehow.

Comment 5

10 years ago
Bill, still see this problem.  Agree with David this doesn't strike me as being a thunderbird problem.  I've encountered similar symptom where problem was router/firewall. 

If you still suspect TB, the please attach smtp+imap log
Severity: critical → major
Whiteboard: closeme 2008-07-01

Comment 6

10 years ago
=> invalid (or incomplete, take your pick)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.