Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 367203
11 years ago
11 years ago

People

(Reporter: barbara, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1.2pre) Gecko/20070211 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1.2pre) Gecko/20070211 SeaMonkey/1.1

After upgrading to seamonkey-1.1 I can't move bookmarks in the Bookmark Manager with dnd.

Reproducible: Always

Steps to Reproduce:
1. open the Bookmark Manager
2. click on a bookmark and drag it

Actual Results:  
nothing happens


Expected Results:  
the bookmark is moved

The following lines are printed to the console:

###!!! ASSERTION: can't get drag session: 'mSlots->mDragSession', file nsTreeBodyFrame.cpp, line 1899
Break: at file nsTreeBodyFrame.cpp, line 1899

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed

(Gecko:1242): Gtk-CRITICAL **: gtk_drag_get_data: assertion `GTK_IS_WIDGET (widget)' failed
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsITransferable.getAnyTransferData]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://communicator/content/bookmarks/bookmarks.js :: anonymous :: line 1447"  data: no]
************************************************************


I currently have the same behaviour in Fedora Core 6
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

I had a similar problem with seamonkey-1.0.7 that was solved upgrading to gtk-2.10.9 discussed here https://bugzilla.mozilla.org/show_bug.cgi?id=355248#c10

Comment 1

11 years ago
Hmm, same assertion as bug 305548.

Comment 2

11 years ago
See also bug 370262

Comment 3

11 years ago
Very likely a dupe of bug 367203, marking as such. Try a nightly for the fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367203
You need to log in before you can comment on or make changes to this bug.