Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

12 years ago
Created attachment 254765 [details]
File that demonstrates the issue

The label of a checkbox wraps to the next line if there is insufficient horizontal space. However this does not work for radio buttons.

I first discovered this on suiterunner (suite with toolkit widgets), but I verified the bug on DPa2 and both Firefox 2.0.0.2 and 1.5.0.10 rcs.

I've marked this as a regression because this isn't a problem in xpfe Classic or Modern themes.
(Assignee)

Updated

12 years ago
Attachment #254765 - Attachment filename: longradio.xul → 370109.xul
WFM, Mac and Linux. Is that because they both wind up with flex=1 on their radio-label-box, while winstripe doesn't, or something deeper I'm not seeing?
(Assignee)

Comment 2

12 years ago
Created attachment 254812 [details] [diff] [review]
Proposed patch

(In reply to comment #1)
>WFM, Mac and Linux. Is that because they both wind up with flex=1 on their
>radio-label-box, while winstripe doesn't, or something deeper I'm not seeing?
The label also needs flex="1"

Interestingly the radio-with-spacing binding is correct.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #254812 - Flags: first-review?(gavin.sharp)
Comment on attachment 254812 [details] [diff] [review]
Proposed patch

I wish I knew why this was incorrectly forked by the "winstripe landing". Maybe it was a forgotten attempt at fixing some other issue they were seeing when developing the theme.
Attachment #254812 - Flags: first-review?(gavin.sharp) → first-review+
Hrm, actually, this patch is causing very strange bustage in my build (I thought it was due to another local patch). I don't see why, at first glance.
Oh, it's because you added an extra "/" after the first flex="1". Please fix that before landing :)
(Assignee)

Comment 6

12 years ago
(In reply to comment #5)
>Oh, it's because you added an extra "/" after the first flex="1". Please fix
>that before landing :)
Sorry about that, I have one tree I like to do diffs from but that involves patching it correctly first ;-)

Fix to fix checked in :-)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.