Closed Bug 370152 Opened 13 years ago Closed 13 years ago

Save Page As... doesn't handle CSS @import properly

Categories

(Firefox :: General, defect, major)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 126309

People

(Reporter: renerattur, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

These days alot of webpages define a CSS stylesheet which has nothing more than a @import to another CSS stylesheet. When one tries to save a page, firefox does not get that imported stylesheet. Most of the time this produces really ugly looking webpages.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.python.org
2. Use File->Save Page As...
3. Open up the newly saved webpage, and enjoy it.
Actual Results:  
**** looking webpage, no layout, no style, no nothing, just plain markup.

Expected Results:  
Pretty looking webpage with layout and styles.

Recursively fetch all @import'ed stylesheets up to a certain threshold.
Dupe of bug 126309.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: @importSave
You need to log in before you can comment on or make changes to this bug.