Setting Firefox to "work in offline mode" disconnects Chatzilla

RESOLVED DUPLICATE of bug 166929

Status

Other Applications
ChatZilla
RESOLVED DUPLICATE of bug 166929
12 years ago
10 years ago

People

(Reporter: Vesa Piittinen, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Chatzilla 0.9.77 [Firefox 2.0.0.1/2006120418]

When setting Firefox to offline mode, for example to retrieve a single page from cache instead of loading a new version, Chatzilla disconnects all servers as well.

Reproducible: Always

Steps to Reproduce:
1. Open up Chatzilla and connect to servers.
2. Go to Firefox, select File | Work in offline mode.
Actual Results:  
Chatzilla disconnects.

Expected Results:  
Chatzilla should keep it's connections: there is no reason to have an offline mode for an IRC client when a connection exists.

I'm not sure of the actual English translation of "work in offline mode" as I don't use English Firefox.

Comment 1

12 years ago
Work Offline in Firefox stops all connections, as it tells the networking code to go offline.

This is probably a duplicate bug, and most likely a wont/cantfix of a duplicate bug, but its outside of chatzilla's control.

Comment 2

12 years ago
There's two bugs, in fact.

Iny, miny, miny mooo.... This one!

PS: and as Wolf said, Firefox actually tells the network components in Mozilla to just seize doing whatever they're doing. You can't tell "just the browser" to go into offline mode. We can, however, ask you if you really want to go offline because you still have open connections, which is what bug 166929 is (partly) about.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 166929
You need to log in before you can comment on or make changes to this bug.