Implement a smart Charset detection for emails

RESOLVED DUPLICATE of bug 251634

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 251634
12 years ago
12 years ago

People

(Reporter: u49640, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Version 1.5.0.9 (20061207)

I often receive emails from amazon with
Content-Type: text/plain; charset=ASCII

but it actually contains ISO-8859-1 characters like "ö", "ä", and "ü".

So i'd suggest to implement some kind of smart charset detector, that switches from ASCII to ISO-8859-1 (or whatever is appropriate) when the email is wrongly declared as ASCII.

(yes, i know the best solution is for amazon to fix their mail program... if anyone has contacts there, this would work too)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

12 years ago
there's already View->Character Encoding->Auto-Detect
(Reporter)

Comment 2

12 years ago
this menu has
chinese
japanes
...
universal

none of them work as they should

if i set it to universal, the encoding looks ok, but i see a lot of garbage (all Mail headers, the plain text part) above the HTML part

I'll upload a screenshot soon
(Reporter)

Comment 3

12 years ago
Created attachment 254943 [details]
Set charset to auto detect
(Reporter)

Comment 4

12 years ago
and btw: this auto-detection should really auto-detect without me having to tell thunderbird to auto-detect ;)

Comment 5

12 years ago
As it happens, "ASCII" is not a legal charset name.  If "us-ascii" were used, the program would display the ISO-8859-1 characters with no problem.

And as seen at the dupe, an illegal charset not only fails to set the charset but manages to prevent autodetect as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 251634
You need to log in before you can comment on or make changes to this bug.