spurious nsIChannel::Cancel() calls

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: dmose, Assigned: Gagan)

Tracking

({perf})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I haven't been able to really track this down yet, but I'm implementing
nsIChannel.  From time to time nsLDAPChannel::Cancel() gets called when I
haven't touch the stop button, and it appears to be happening after the channel
has already fired nsOnStopRequest().  I'll add more info to this bug if more
details emerge.
(Assignee)

Comment 1

18 years ago
it would help to see where the cancel call is coming from. See if you can get
that in the stack... cc'ing ruslan
(Assignee)

Comment 2

18 years ago
m17 for now till we can get better idea.
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 3

18 years ago
With new FinalListener business it's not going to cause any harm anymore :-)
(Reporter)

Comment 4

18 years ago
Well, except for the fact that it wastes cycles.
Keywords: perf
(Assignee)

Comment 5

18 years ago
it seems that the root cause of this bug might be related to bug 38281. cc'ing
rpotts. 
(Assignee)

Updated

18 years ago
Target Milestone: M17 → Future
(Assignee)

Comment 6

18 years ago
cc'ing mscott on this one. 

Comment 7

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 8

14 years ago
this looks like a dead bug.  dmose: any reason to keep this open?

marking WORKSFORME
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 9

13 years ago
V, per Darin
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.