Last Comment Bug 370495 - Wrong message in shared IMAP folder gets moved to junk folder when manually marking message as junk
: Wrong message in shared IMAP folder gets moved to junk folder when manually m...
Status: RESOLVED DUPLICATE of bug 324777
:
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: SeaMonkey 1.1 Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 168648 324777
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-15 05:52 PST by karlsen
Modified: 2011-04-19 09:03 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description karlsen 2007-02-15 05:52:22 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1

I use an IMAP mail account.

When I mark a mail manually as Junk in say IMAP mail folder A using the mouse clicking onto the bullet in the Junk column Seamonkey is marking the mail as Junk.

This is expected up to this point.

But:

When Seamonkey is just going to move the mail from that mail folder A into the Junk folder and simultaneously a new email is arriving via IMAP in that same mail folder A, Seamonkey is actually moving this new arrived message into the Junk mail folder instead of the marked Junk mail.


Reproducible: Sometimes

Steps to Reproduce:
Due to the fact that I can't produce deterministic incoming IMAP emails and the fact that I need to click the Junk mail marker at some specific time it is difficult to reproduce.

But funny enough it happens quite too often that a new mail arrives whilst at the same time I mark some mail in the same mail folder as Junk. (10 to 20 times a day on a high traffic exposed mailbox with lots of SPAM).

1. Mark an email as junk in a folder just when IMAP delivers/displays a new email into that folder.


Actual Results:  
1. New email is marked read and moved into the Junk folder.
2. Marked Junk mail is marked Junk but stays in the normal mail folder.

Expected Results:  
Well the expected result is obviously that the new mail stays in the folder as 'new' mail and the marked Junk mail moves over as marked read into the Junk folder.

If you don't look close, if there is an incoming mail whilst you mark an existing mail as SPAM it is easy to accidentally lose HAM mails to Junk mail folder.
Comment 1 WADA 2007-08-31 20:24:17 PDT
(In reply to comment #0)
> But:
> When Seamonkey is just going to move the mail from that mail folder A into the
> Junk folder
> and simultaneously a new email is arriving via IMAP in that same
> mail folder A,
> Seamonkey is actually moving this new arrived message into the Junk mail folder 
> instead of the marked Junk mail.

Sounds variation of Bug 324777, which seems to be similar problem to Bug 168648, although IMAP case often involves different problem/cause(networking related) from POP3 case. 
> This bug: Junk move by manual mark as Junk fails if Junk move by Junk filter occurs at same time

Setting dependency to 324777
Comment 2 Peter Weilbacher 2008-03-27 10:14:31 PDT
I often mark messages as junk, both by pressing J and clicking with the mouse. But this has never happened to me with any of the three IMAP servers that I have used, even though I get lots of mail and sometimes those other emails appear in my INBOX close in time to my mouse/keyboard operation.
It's also not clear to me what "simultaneous" means in this case, as the move operation should only take a few milliseconds and clicking at exactly that time is highly unlikely.

karlsen: if you are still seeing this with current versions, can you provide an excerpt of your junk log (you might have to activate that in the account settings)? Otherwise this is either "incomplete" or "worksforme".
Comment 3 karlsen 2008-03-28 01:40:24 PDT
Got the message.

I will try this with Seamonkey 1.1.9.

Since it happened to often that I lost HAM accidentally I refrained from using the Junk marker (or j key) on the affected IMAP mailboxes. So I don't have uptodate info on this.

I will restart again using the Junk marker now, to see if the reported behavior vanished during the last year or is still in 1.1.9.

I will let you know shortly.
Comment 4 karlsen 2008-03-31 04:53:40 PDT
Ok,

it is still there. Just happened again.

But it seems that marking an email as junk in this IMAP folder manually does not show up in the Junk log at all.
Comment 5 karlsen 2008-03-31 05:29:49 PDT
I found it very difficult to describe this weird behavior thus I will try to describe it again.

I see how many mail addresses subscribe to this bug, so it seems that there are more people out there who may have hit the same problem...

Here goes:

Setup:

Seamonkey is checking E-Mails every 5 minutes automatically.

My Seamonkey Mail-Account is an IMPA mail account which subscribes to a few additional IMAP mail folders on my IMAP server.

Say the affected IMAP folder is called "Team Box".

This folder is not a sub-folder of the "Inbox" folder.

In "Folder Properties" of the "Team Box" folder the checkbox "Check this folder for new messages" is checked.

I also have IMAP subscriptions to further sub-folders of "Team Box".

Since it is a team mail box several more people have IMAP access to the "Team Box" folder and they are allowed to delete mails from the "Team Box" folder as well.

I have a very well trained Junkmail database and I have enabled Seamonbkeys automatic Junkmail processing. Despite of this, obvious Junk mails in the "Team Box" folder are not processed automatically by Seamonkeys Junkmail filter engine. I always put that to the fact, that this "Team Box" folder is not a sub-folder of my "Inbox"...

Anyway. If I look at "Team Box" emails in the mail panel, I see an unread obvious Junk Mail next to some other ham mails.

I click the "Mark as Junk" Button in the line of the Junk Mail (in the column "Click to sort by Junk status").

The Junk Mail gets marked a Junk but is not moved anywhere. Instead the ham mail just above (ordering of mails in "Team Box" is by Date/Time newest mail upmost) the Junk mail is moved to my Junk folder. ops.

I have some thoughts why this could happen:

It may be that a colleague accessing the "Team Box" in parallel just deleted the real Junk mail as well, my Seamonkey still displaying it. So Seamonkey (in its 5 minutes refresh/poll mode) does not know that the real Junk mail is already gone. When I mark it as Junk in the mail overview pane mail indexes/IDs get mixed up or what ever and the wrong (aka ham) mail is moved into the Junk folder instead...
but on the other side the real Junk mail is still in the "Team Box" folder which does not fit the theory that a colleague has deleted it out of the "Team Box".

My Junk log does not show any entry from me marking the mail as Junk manually...

Well, ideas are welcome. What else can I do to help finding the reason for this weird behaviour?

R

Comment 6 Peter Weilbacher 2008-03-31 06:05:57 PDT
Ah, I didn't get from the previous comments that the folder is a shared one. (I'm trying to edit the summary to reflect this.) That would also explain why I don't see that problem because I have never used shared IMAP folders. I don't know anything about the algorithms to handle them, one would think that there was some locking mechanism implemented for cases like this. Searching for shared IMAP folders in Bugzilla doesn't show me any obvious big bugs, though, that would happen if such locking was not happening. Bug 360433 seems only remotely related.

You are right, manually marking as junk does not show up in the junk log, sorry for the confusion! But perhaps if you try the MailNews troubleshoot guidelines from <http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap> something might be listed in that logfile about which messages were marked and which were actually moved. Not sure though, if anybody is available to actually make sense of these logs if you take them and attach them here...
Comment 7 karlsen 2008-03-31 06:28:18 PDT
I'm going to debug this with the env variables suggested in referenced links...maybe something show up.

I forgot to mention that the ham mail that is accidentally moved to the Junk folder is not marked as "Junk".
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2011-04-19 09:03:38 PDT
duping. If you still see this after bug 324777 is closed then please reopen this bug

*** This bug has been marked as a duplicate of bug 324777 ***

Note You need to log in before you can comment on or make changes to this bug.