Closed Bug 370570 Opened 14 years ago Closed 14 years ago

Highlight within text fields breaks editing of text

Categories

(Toolkit :: Find Toolbar, defect)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 256989

People

(Reporter: george.s.bills, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060313 Fedora/1.5.0.1-9 Firefox/1.5.0.1 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060313 Fedora/1.5.0.1-9 Firefox/1.5.0.1 pango-text

When using highlight on a page with a text field / text area, any highlighted words within that text area are not editable - the user cannot even insert a cursor within the word.

Reproducible: Always

Steps to Reproduce:
1. Go to any Wikipedia article.
2. Click "edit".
3. Click "preview".
4. Open find, find a word present within the article (and thus the edit text field).
5. Click "highlight". The word found should now be highlighted inside both the preview and the text field.
6. Go to the text field, and try to edit any highlighted word.
Actual Results:  
Highlighted words within a text field are not editable.

Expected Results:  
Highlighted words within a text field should be editable.
This is worksforme with  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070215 Minefield/3.0a3pre
Did you also test this with the latest version (installed in a new empty folder) and with a new profile without extensions?
http://www.mozilla.com/
http://kb.mozillazine.org/Profile_Folder
Duplicate of bug 256989.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 256989
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.