Disclosure triangles are really picky about where you click

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
11 years ago
6 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
I seem to have to click very precisely in the upper middle area of disclosure triangles in the message list in order to expand a thread.  It's really hard to get it right; I almost always have to click two or three times before I hit the sweet spot.

Comment 1

11 years ago
Which version of Thunderbird are you using?

Are the triangles ("twisties") that you're having problem with in a particular part of the program -- folder pane, envelope panel -- or everywhere?

Do you have the same problem with Firefox (say, in the Bookmark Manager)?
(Reporter)

Comment 2

11 years ago
About box says "version 2 beta 2 (20070116)".

The problem actually seems to be with all of the triangles, and you're right, it seems to happen in Firefox as well.  I just almost never use the bookmark manager in Firefox so I didn't really notice it there.  I have to open threads in the message window all the time in Thunderbird so it's pretty aggravating there.

It seems to want me to click in a roughly 3-by-3 pixel area in the center-left of the triangle.  I would expect the entire triangle to be clickable.

Comment 3

11 years ago
Wayne, can you help Eric? do you see this on MAC?

Comment 4

11 years ago
Hi Eric, your version of Thunderbird is a rather old beta. While I'd still recommend you update to the final release (2.0.0.6), I'm sorry to report it won't fix your problem.

While I can't reproduce your problem *exactly* as you put it (localized to several pixels), I do experience a general lack of consistency in the responsiveness of those arrows. Sometimes clicking on particular pixels work, other times they don't (I'm using Pixie to target specific pixels).

In the Thunderbird trunk (3.0 alpha) versions, I can report that the responsiveness is much better. I'm not sure what changed, exactly. One bug I experience, however, is that it fails if you click again too soon after the first click, so it's not perfect. I'll leave it to Scott to decide if anything should be done on the 2.0 branch.
(Reporter)

Comment 5

11 years ago
Well, when I filed this report, that beta was the latest build.  Definitely still a problem in 2.0.0.6.  It's really hard to make those twisties twist. :)

Updated

11 years ago
Version: unspecified → 2.0

Comment 6

10 years ago
This bug seems to be fixed in the latest OS X builds. In the official release the clickable area of the icons indeed didn't extend far enough to the right (clicking in the rightmost part of the icon had no effect).

Updated

9 years ago
Assignee: mscott → nobody

Comment 7

6 years ago
Eric, is this still a problem in current versions of TB?
I'd think not. We could add a little margin before (to the left of) the folder twisty (would need a new bug), but otherwise we allow clicking with some px margin around the actual twisty icon. Didn't check any other twisties.

Suggesting closeme wfm.
Whiteboard: closeme 2011-11-29

Updated

6 years ago
Whiteboard: closeme 2011-11-29 → [closeme 2011-11-29]

Comment 8

6 years ago
let's say WFM per comment4 and 6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-11-29]
You need to log in before you can comment on or make changes to this bug.