Downloaded mail shows up as blank instead of the actual mail

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Judith Hellerstein, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Thuderbird 2 beta 2

I tried using Thunderbird 2.0 beta 2 to download my mail and while the headers are correct, I can not read the mail since each mail that is open is blank. I can read the mail using Thunderbird 1.5.0.9 and on pine.

The only mail that was downloaded correctly was mail from 2/12 all mail after this date shows up as blank.  I tried to look at the source code and that is blank as well.

Reproducible: Always

Steps to Reproduce:
1.go online
2.read and open a piece of mail
3.Mail is blank


Expected Results:  
Mail should be easily able to see when it is online as well as off line and should not show up as a blank box

Comment 1

12 years ago
Can you attach an imap protocol log? I assume this was imap...
<http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap>
(Reporter)

Comment 2

12 years ago
Created attachment 255611 [details]
Attempt to write command code to get IMAP logs

See my earlier email for detailed info on the file
(Reporter)

Comment 3

12 years ago
I tried to do this, but was not able to get it set up.  I really do not know code for the mac and tried to have a friend who knows PCs show me how to do this,but he was not successful either. He wrote the text file as the website stated and saved it as a terminal.app file, but we could not get it to execute.  Does it need to be in the same folder as thuderbird.  I tried launching it from the desktop, but it did not work.  I would appreciate if  you could give me some detailed information on how to do this.

I renamed Thunderbird 2 beta 2 as newThunderbird and placed it in the Applications folder along with Thunderbird 1.5.0.9 which I am still using.  I can attach this file

I did look in the error logs in thuderbird 2 beta 2 and found this

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIIOService2.manageOfflineStatus]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mail-offline.js :: anonymous :: line 56"  data: no]

Comment 4

12 years ago
That one line should say 
export NSPR_LOG_MODULES=IMAP:5

The error console error is unrelated (and have been taken care of in the nightly builds).
(Reporter)

Comment 5

12 years ago
In browsing the Thunderbird Forums, I found others with the same problems, but on Windows XP and the commonality seemed to be a problem with compacting folders.  I accidently hit compact folder instead of empty trash and I think that is when my problems with my mail started occuring. I am unable to get the imap logs to upload as attachments since I do not know how to get Thunderbird to run from the command prompt.  I corrected the problem that you noticed, but still cannot get it to launch thunderbird so it can capture the logs.

It says,/Users/judith/Desktop/thunder.command; exit
Welcome to Darwin!
[Judith-Hellersteins-Computer-2:~] judith% /Users/judith/Desktop/thunder.command; exit
tcsh: /Users/judith/Desktop/thunder.command: Command not found.
logout
[Process completed]

Comment 6

12 years ago
You may want to delete the .msf file for the folder. You can find it in your profile folder: <http://kb.mozillazine.org/Profile_folder>

I don't no anything about mac, but that message I guess is either about wrong path to thunderbird or wrong path to the file to enable logging.
(Reporter)

Comment 7

12 years ago
OK I went to my profile which is still called default and found the .msf files int he imap folder.  I first made a copy of the inbox.msf folder and then deleted the original and had Thunderbird download the files again. This did not work since now all files can not be viewed offline while before only the files that were after Feb 12 could not be viewed offline. I then trashed the new inbox.msf file I just had rebuilt and replaced it with the original one.
(Reporter)

Comment 8

12 years ago
There is something wrong with the Thunderbird instructions for creating IMAP logs.  

The Thunderbird instructions for Mac tell me to do the following

#!/bin/sh
export NSPR_LOG_MODULES=IMAP:5
export NSPR_LOG_FILE=filename (in my case thunder.command)
/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin &

but while I can launch thunderbird from the command prompt by just using the last line of the script, I get a command not found when I include the first three lines.  I verified this today with the technicians in the Apple store. They told me that there seems to be a problem with the script from Thunderbird as no logs are created.

Any suggestions about a correct script to use on the Mac OSX 10.4.8

Judith
(Reporter)

Comment 9

12 years ago
Just realized my mistake in my earlier comment, When I said I tried to use the command script from the knowledgebase

#!/bin/sh
export NSPR_LOG_MODULES=IMAP:5
export NSPR_LOG_FILE=filename (I meant to write--IMAP.log and not thunder.command) Sorry about this.  Hope this clarifies the issue

Any suggestions about a correct script to use on the Mac OSX 10.4.8 or how I can avoid getting the error command not found when having all three lines in the same script.

Each line appears to work individually it is just the combination of all 4 that does not work.

Judith

Comment 10

12 years ago
Don't know what the problem is, but you can also just enter the last tree lines (everything but #!/bin/sh) directly on the command line. 
(Reporter)

Comment 11

12 years ago
Magnus,

OK I tried this, but no logs seem to have been created.  I did a search.  I got this result

judith% export NSPR_LOG_MODULES=IMAP:5
tcsh: export: Command not found.

export NSPR_LOG_FILE=/Users/judith/imap2.log

/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin &

[Judith-Hellersteins-Computer-2:~] judith% 
[Judith-Hellersteins-Computer-2:~] judith% export NSPR_LOG_FILE=/Users/judith/imap2.log
tcsh: export: Command not found.
[Judith-Hellersteins-Computer-2:~] judith% 
/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin &
[1] 650
[Judith-Hellersteins-Computer-2:~] judith% 

Any other suggestions?

Comment 12

12 years ago
If that's tcsh, try
setenv NSPR_LOG_MODULES IMAP:5
setenv NSPR_LOG_FILE /Users/judith/imap2.log
(Reporter)

Comment 13

12 years ago
Magnus,

This finally worked!!

That was the missing step.
I tried to attach the imap log file that was generated with the new command request, but Bugszilla told me the file is too large and told me to upload it to my website so here is the link

www.jhellerstein.com/imap2.log

  Hopefully this will tell you what is going on.  

do you need me to get logs for Thunderbird 2 beta 2? 

Judith
(Reporter)

Comment 14

12 years ago
Sorry I forgot to say that this logs are for Thuderbird 1.5.0.9 and not for Thunderbird 2 beta 2

Judith

Comment 15

12 years ago
Sorry, didn't spot any obvious problem from that log. Do try with the beta 2 also, since that was what this bug was about. 
Version: unspecified → 2.0
(Reporter)

Comment 16

12 years ago
Magnus,

Here is the link to the logs for Thunderbird2 beta 2
www.jhellerstein.com/imap.log

Did the logs tells you why the messages were not downloading correctly.  Will it tell you anything about the profile and whether it is corrupted?

Did you say I should upload the Thunderbird 1.5.0.9 to the bug I set up for that problem

Thanks!!
Judith

Comment 17

12 years ago
So, we have 
1) tb1.5.0.9: http://www.jhellerstein.com/imap2.log
2) tb2.0 beta 2: http://www.jhellerstein.com/imap.log

The messages doesn't seem to get downloaded in 2). But i don't see any obvious error message...


(Reporter)

Comment 18

12 years ago
Why is that. I would have thought there would be or should be an error message I was hoping the logs would tell me why the messages were not downloaded?  I noticed the file size was a lot smaller, 2gb for tb1.5.0.9 and only about 400k for tb2.0 beta 2.

I have the setting set for download messages offline, but they do not seem to download as the logs indicate. Both programs access the same profile? Could that be a problem?

I got this message on the command prompt after the command
[Judith-Hellersteins-Computer-2:~] judith% Warning: unrecognized command line flag -foreground

But I think it was that I hit return or enter, but maybe it was telling me something instead

Any other advice of how the problem could be fixed

Judith

Comment 19

12 years ago
Judith, how big is your IMAP Inbox file, the offline store? I'm starting to wonder if it's > 2GB. You could simply delete the INBOX and Inbox.msf file, and let TB re-download the headers and message bodies for the offline store.
(Reporter)

Comment 20

12 years ago
David,

My file is very large, but not that much great than 2mb. However, the mail stored in this file is less than 1mb. I think the file got large since I have never compacted it.  I never knew this was a problem.  In October the main imap inbox mailbox was emptied by my provider when they moved my inbox to another file in a different location because it got to be too large. So the inbox os only from November and I have been keeping it pretty small.I had not known you needed to compact the inbox when you use IMAP. I think I accidently did this on 2/13 and this is what started the problem, but not sure.

What I did try was to delete the .msf file and have Thunderbird rebuild it. I did not delete the inbox file, just the ,msf file.  When Thunderbird, ie, 1.5.0.9 and Thunderbird 2beta 2, rebuilt it the problem got worse. Whereas before all emails prior to 2/12/07 could be viewed offline (from 11/06-2/12/07), with the mails after that date never downloading properly.  When the .msf file was rebuilt, none of the mail could be viewed off line but those after that date could no longer be seen. Under 1.5.0.9 the system would just say loading but the mail would never appear.  In Thunderbird 2 beta 2 the mail would open and be blank

I have never deleted the actual Inbox file, just the inbox.msf file.

Hopes this help clarify the issue and maybe gives you more ideas of what is going on

Thanks!!

Judith
(Reporter)

Comment 21

11 years ago
Magnus, 

I downloaded thunderbird to another computer, a mac running 10.3.9, that never had thunderbird on it and recreated a profile and then told it to get the mail from IMAP.  The mail does not show up as blank, but I get the standard message "The body of this message has not been downloaded from the server for reading offline. To read this message, you must reconnect to the network, choose Offline from the File menu and then select Work Online. In the future, you can select which messages or folders to read offline. To do this, choose Offline from the file menu and then select Synchronize. You can adjust the Disk Space preference to prevent the downloading of large messages."  Of course when I try to do this nothing happens. so I think that there is still a problem with Tbird 2 beta 2 in how it works with macs and with imap?

Should I create new imap logs for this?

I  would have expected that the problem would disappear with a fresh download since I would be creating a brand new profile and that would fix all problems, but it does not.  I tjust makes all files prior to 2/12 also not downloading. Actually I think no files ahve downloaded. 

Judith

Comment 22

11 years ago
Judith, I may have missed this - did you tell Thunderbird that you want to sync your IMAP inbox for offline use, and did you tell it to download the messages for your inbox for offline use?

File | Offline | Offline settings, Select folders for offline use, check inbox, or check the Make messages in my inbox available when I'm working offline

And then, File | offline | download and sync now?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 23

11 years ago
David,

Yes I did, but none of that works with the new profile, just as it did not work with the old profile.  Everything is appropriately checked, but the messages will not download. It is a continuation of the old problem but now with the new profile on a separate machine.

Judith

Comment 24

11 years ago
Judith, did you look at the INBOX file in your user profile directory with a text editor, and see if it has the text of your messages in it?
(Reporter)

Comment 25

11 years ago
David, The computer with the fresh and new profile does not have an Inbox file, just an inbox.msf file. Not sure why it does not have an Inbox File. I did look at the inbox.msf file with a text editor and it is just the headers and the email address in it as well as a bunch of code I do not understand.

Does this provide you with any clues?

Judith

Comment 26

11 years ago
If you bring up folder properties on the imap inbox, and click the Offline tab, is the "select this folder for offline use" box checked? If so, at the very least, I would expect that reading an imap message in your Inbox would cause the INBOX file to get created.
(Reporter)

Comment 27

11 years ago
David,

I have checked the box as you describe Read the message on line. Clicked download mail offline, went off line but mail could not be read and no Inbox was created, just the Inbox.msf file. That is why I am saying it is a bug that affects IMAP users who do not filter their mail on Macs

Judith

Comment 28

11 years ago
I don't filter my imap e-mail on the mac and offline works just fine...I'm at a lost as to what's going on for you...
(Reporter)

Comment 29

11 years ago
David & Magnus,

Here are the new logs for this Ibook which has a fresh profile and is running Thunderbird 2 beta2.  Even though i have used the email on this computer for almost a week, it still never created a file in IMAP mail called Inbox.  I just have a file called inbox.msf. Could this be what is happening and why mail is not downloading correctly offline.  Here is my new log.  It is called imap3.log, www.jhellerstein.com/imap3.log. Hopefully this will give you some clue

Thanks again for your help

Cheers!!
Judith

Comment 30

11 years ago
Don't know if it will help, but that link is not working.
(Reporter)

Comment 31

11 years ago
Sorry. :-(  I did it late at night and did not realize I had put it in the wrong directory. try it now.

Another problem I am having is tht I can not open more than one email at the same time.  When I try and open a second one, the first email closes. Should I file a separate bug report for this?

Judith

Comment 32

11 years ago
No, that's a configuration thing. Options > General > Advanced > Open new msgs in.

Sure looks like the mail is downloaded, in the logs from http://www.jhellerstein.com/imap3.log
(Reporter)

Comment 33

11 years ago
Thanks for the tip.  I did this. In the mac it is under preferences as there is no options tab.

the mail still is not downloaded even though that is what it seems tohave done. As soon as I go offline to look at the mail, it says mail has not been downloaded for offlien viewing, when it has. If you go online and download it again and look at it, it may open, but there really is no copy saved since if Tbird thinks it is junk or spam and puts the tag on it if you click the tab to say it is not spam, the message disappears and says message has not been downloaded for online viewing and tells me to adjust my settings. The settigns are already set to download all mail, but mail does not seem to ever download

So we still have the same problems and worse now that the logs do not even show there is a problem.  Any other suggestions on how to get this bug fixed?

Thanks for all your help

Judith
(Reporter)

Comment 34

11 years ago
Problem has been fixed.  There was no inbox file created, which is what caused the problem. When I did the reinstall and used an second clean copy it worked. Sorry was not able to report this earlier but was on vacation with no access to email.  I reinstalled and redid all the settings  Apparently you need to check download mail while offline in two different menu items in Thunderbird 2 beta 2.  If the box was not checked in both places, Mail would not be downloaded and no INBOX file would be created.  Once I did this and rechecked the mail, I got everything to download.

Once I had success with this, I did the same on the other computer.  I also made a copy of the inbox and the inbox.msf file and then deleted both of these from the profile and rebuild by Inbox folder and it seems to be working correctly now.  I had previously tried just deleting the .msf file, but that did not work.  Both files needed to be deleted. Thanks for everyone's help.

Judith

Comment 35

11 years ago
(In reply to comment #34)
> email.  I reinstalled and redid all the settings  Apparently you need to check
> download mail while offline in two different menu items in Thunderbird 2 beta
> 2.  If the box was not checked in both places, Mail would not be downloaded and
> no INBOX file would be created.  Once I did this and rechecked the mail, I got
> everything to download.

Which two menu items do you mean?

Updated

11 years ago
Duplicate of this bug: 370451

Comment 37

11 years ago
Magnus, I'm sure she means that there's "Download messages for offline use when
going offline?" Yes/No/Ask in Advanced..Network and Disk Space, and then
there's also "Make the messages in my inbox available when I am working
offline", under Tools..Accounts..Offline and Disk space... AND then there's
(also under Tools..Accounts..Offline and Disk space...) "Select folders for
offline use...".
So there's kinda 3 places.  

Comment 38

11 years ago
Judith, still see this problem with current v2.0.0.9?

Comment 39

10 years ago
TB version 2.0.0.12 (20080213), WinXP

I have set up three of my accounts as gmail IMAP accounts. Previously they were accessed by POP. Been using them in IMAP mode for about three months now. Once a day or so TB will download headers only, but the message body is blank in preview and if I open the message. The messages are not blank if I view them through the gmail web interface. Going to another inbox then return to the affected one does not make the message unblank, however it appears that exiting then re-launching TB DOES make the message visible. 

Comment 40

10 years ago
After posting Comment #39, it was suggested to me that I set TB to write a log file, per Comment #1. The linked Windows batch file suggestion is:

set NSPR_LOG_MODULES=protocol:5
set NSPR_LOG_FILE=c:\tmp\filename
start mozilla

Which I re-wrote as 

set NSPR_LOG_MODULES=IMAP:5
set NSPR_LOG_FILE=c:\temp\TB_IMAP_log.txt
"C:\Program Files\Mozilla Thunderbird\thunderbird.exe"

to get it to work. It creates a logfile whenever TB is launched, and I've had several incidents where IMAP messages are coming up blank, but are not when I go to the gmail web interface, yet the logfile never has any information written to it. I have checked it while TB is running, after errors occur, and after exiting TB, still empty.
I've also changed the Error_Level from 5 to 4, since the article doesn't mention 5 as an option, with no effect on the logfile: nothing ever gets written to it. Sorry I can't provide this possibly useful debugging information. 

The problem is continuing (blank IMAP emails which are not blank when viewed with the web interface) and I was incorrect about it being self-correcting by exiting and re-launching TB, the messages remain blank.

Comment 41

10 years ago
Mike, here is a newer document -- I don't know why you are having trouble. Perhaps you and Gary can figure it out?
http://wiki.mozilla.org/MailNews:Logging
Assignee: mscott → nobody

Comment 42

10 years ago
=> WFM per reporter's comment 34
Mike, if  you still see a problem, please open a new bug and reference this one.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.