Vertical RTL marquee appears outside its container

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: uriber, Assigned: uriber)

Tracking

({regression, rtl, testcase})

Trunk
PowerPC
Mac OS X
regression, rtl, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

12 years ago
Created attachment 255464 [details]
testcase

In the URL above, notice that the news ticker on the left appears to the left of its intended position (which is inside a table cell).
The testcase shows that this also happens when a container is an RTL div. 

This regressed between 2007-01-27 and 2007-01-28, almost certainly due to the fix for bug 163504.

Note also that horizontal RTL marquees have been broken for a while (bug 336736).
Flags: blocking1.9?
Probably margin-right: 100%; at:
http://lxr.mozilla.org/seamonkey/source/layout/style/xbl-marquee/xbl-marquee.xml#667
needs to be -moz-margin-end: 100%;
(Assignee)

Comment 2

12 years ago
Yeah... patch coming right up.
(Assignee)

Comment 3

12 years ago
Created attachment 255467 [details] [diff] [review]
patch

What Martijn said.
Assignee: nobody → uriber
Status: NEW → ASSIGNED
Attachment #255467 - Flags: superreview?(dbaron)
Attachment #255467 - Flags: review?(dbaron)
Comment on attachment 255467 [details] [diff] [review]
patch

r+sr=dbaron
Attachment #255467 - Flags: superreview?(dbaron)
Attachment #255467 - Flags: superreview+
Attachment #255467 - Flags: review?(dbaron)
Attachment #255467 - Flags: review+
(Assignee)

Comment 5

12 years ago
Checked in:
Checking in mozilla/layout/style/xbl-marquee/xbl-marquee.xml;
/cvsroot/mozilla/layout/style/xbl-marquee/xbl-marquee.xml,v  <--  xbl-marquee.xml
new revision: 1.27; previous revision: 1.26
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Flags: blocking1.9?
Resolution: --- → FIXED

Comment 6

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.