unicode file name not preserved by Send To (MAPI)

RESOLVED DUPLICATE of bug 1048658

Status

defect
--
major
RESOLVED DUPLICATE of bug 1048658
13 years ago
5 months ago

People

(Reporter: 1983-01-06, Unassigned)

Tracking

({l12y})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: 1.5.0.9

mailing a unicode-named file with TB the name gets chopped off!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reporter

Comment 1

13 years ago
Posted image failure
the file in the folder you see is the one I have attached through send to -> email

the result is visible in the background

Comment 2

13 years ago
I'm not sure how you got to that state.  With 1.5.0.9, the results I see with a Unicode filename (and an en-US Windows install) replaces every character that doesn't fit in Windows-1252 with an '_'.

With 2.0, the name appears correctly in the compose window, but still can't be sent; this is bug 332110.
Reporter

Comment 3

13 years ago
Mike,

all I did was: right click on the file -> send to -> email -> there TB pops up with a new compose window which already contains the attached file with altered name!

Comment 4

13 years ago
OK, I see that.  Thanks for the clarification.

Reproduced with TB 2b2-0217 and 3a1-0214, Win2K.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Summary: unicode file name are not preserved by TB → unicode file name not preserved by Send To (MAPI)
Version: unspecified → Trunk
Reporter

Comment 5

13 years ago
Mike,

great you could reproduce it!

hope this will be fixed for 2.0
Assignee: mscott → nobody
michael-o, do you find this fixed in
ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-trunk/
(backup you profile first)

perhaps fixed via bug 33451
Reporter

Comment 7

11 years ago
Wayne,

send to mail did not work although I have registed it as my default client but I was able to drag files into the compose window and send them sucessfully. This operation failed in 2.0. This bug maybe fixed.
Keywords: l12y

Updated

5 months ago
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1048658
You need to log in before you can comment on or make changes to this bug.