Using nicknames in form filling (Give user selective control over what Address Book card data is used)

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
12 years ago
4 years ago

People

(Reporter: kristarella, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

I think it would be good if you could use nicknames in Camino's form filling, or even better, to be able to specify which of your info is given out.
Reasons: I don't give my full name to every site on the net, nor my personal email address. I also don't want to fill out my screen name, email and home page every time I comment on a blog (rather often).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

12 years ago
Duplicate of this bug: 370854
Er, no offence, but if you don't want to automatically fill in everything, why would you be using auto-fill in the first place? Are there situations in which you *do* need to auto-fill such information as screen name and home page? (If not, you can avoid filling these simply by not filling them in on your Address Book card.)

cl
(Reporter)

Comment 3

12 years ago
I do want to fill in all the information on a form, it's very rare that I actually have to fill out my full name in a form since the most common form I use is commenting on blogs (most of the forums et that I sign up to don't require a full name either). After going from Firefox to Camino the most obvious annoyance is having to type in my screen name, email and URL every time I write a comment. Another way to do this would be to make a separate card with screen name, email and homepage but then Camino seems to only use the "Me" card.

Comment 4

12 years ago
We should definitely consider allowing people to specify a different card if there's a reasonable way to do that; it would let people control a lot of things about how form-fill works.
Yeah, that sounds like a good idea (and a fairly practical way to implement something like this, which could otherwise be really messy).

Updated

12 years ago
Component: HTML Form Controls → OS Integration
QA Contact: form.controls → os.integration
Confirming to consider an option for giving users more control here.  I personally support something like comment 4.  FWIW, we get a fair amount of feedback requesting something similar to this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Using nicknames in form filling → Using nicknames in form filling (Give user selective control over what Address Book card data is used)
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.