Support external editing in composer (conflict dialog)

VERIFIED DUPLICATE of bug 27820

Status

P1
enhancement
VERIFIED DUPLICATE of bug 27820
19 years ago
15 years ago

People

(Reporter: cmanske, Assigned: cmanske)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Assignee)

Description

19 years ago
The user can edit a page in both Composer and an external editor at the same 
time. They can save changes to the file with an external editor.
When edit a file in Composer, we need to store the file timestamp and when
we receive focus in a Composer window, we need to check the file timestamp 
against the start time. This will allow detecting changes made by the external
editor. If the user has not made any changes in the Composer version while 
editing in the external editor, all we need to do is put up a "Yes" "No" 
message asking if they want to load the new file version.
If they made changes in the Composer version *and* in the external version and
then saved the external version, there is a conflict and the dialog needs to
be very explicit about telling user to choose one or the other version (the 
one in Composer memory or the version on disk.) We do exactly this in 4.7, so
please review the messages there to evaluate if the strings are ok to use
in mozilla.
(Assignee)

Comment 1

19 years ago
The strings for this dialog should be decided in m16. Complete implementation 
may wait?
Status: NEW → ASSIGNED
Whiteboard: beta2 feature
Target Milestone: --- → M16
(Assignee)

Comment 2

19 years ago
*** Bug 37091 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Severity: normal → major
Keywords: nsbeta2
Priority: P3 → P1
Whiteboard: beta2 feature → nsbeta2 feature

Comment 3

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  But feel free to check in 
prior to 5/16
Whiteboard: nsbeta2 feature → [nsbeta2-] feature
(Assignee)

Comment 4

19 years ago
Dialog work is done. Remaining is to get the file date when getting focus
on the document to detect if page was modified by an external editor.

Comment 5

19 years ago
m17
Target Milestone: M16 → M17

Updated

19 years ago
Whiteboard: [nsbeta2-] feature → [nsbeta2-]

Comment 6

19 years ago
setting to m18, editing from an external editor is quite common, this needs to 
be fixed
Keywords: nsbeta2 → correctness, nsbeta3
Whiteboard: [nsbeta2-]
Target Milestone: M17 → M18

Comment 7

19 years ago
adding nsbeta3+
Whiteboard: [nsbeta3+]

Comment 8

19 years ago
Change summary to better reveal what this bug is about.
Summary: Implement dialog to ask user which version to use when there's conflicting new content. → Support external editing in composer (conflict dialog)
(Assignee)

Comment 9

19 years ago
We can live without this for 1st release, since we don't access an
external editor from within Composer
Target Milestone: M18 → Future

Comment 10

19 years ago
setting to nsbeta3- since this is futured, also adding helpwanted to the 
keywords
Keywords: helpwanted
Whiteboard: [nsbeta3+] → [nsbeta3-]
Adding keyword: relnoteRTM, removing Simone from cc list and adding myself
Keywords: relnoteRTM

Comment 12

18 years ago
Nominating mozilla1.0 and nsbeta1 to trigger consideration for those releases 
since this appears to have been languishing in release notes since Netscape 6.0. 
When editing web pages using Nav4.7 Composer, I almost always have the file open 
simultaneously in Composer and a text editor (in my case, UltraEdit). Would be 
really nice if Mozilla Composer would support the same automatic detection of 
changes so I didn't have to keep track in my head of which one made the last 
change.

Checking a file timestamp, showing a dialog, and reloading from disk if the 
Composer version is older doesn't seem like a lot of code--could we get this in 
for nsbeta1/mozilla1.0?
Keywords: mozilla1.0, nsbeta1

Updated

18 years ago
Keywords: 4xp

Comment 13

18 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 14

18 years ago
Removing nsbeta* keywords from this bug since it's future and we have more 
important things to fix before implementing this functionality.
Severity: major → enhancement
Keywords: nsbeta1, nsbeta3
OS: Windows NT → All

Comment 15

17 years ago
removing myself from the cc list

Comment 16

17 years ago

*** This bug has been marked as a duplicate of 27820 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 17

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.