Alarm occurs 18 hours ahead of time

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: BlueRubicon+Mozilla, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

Alrms set to notify 8 hours ahead actually notify 18 hours ahead.

Reproducible: Always

Steps to Reproduce:
1. Set alarm to notify 8 hours ahead
2.
3.
Actual Results:  
Alarms notifies 18 hours ahead.

Expected Results:  
Expect 8 instead of 8+10.
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2pre) Gecko/20070216 Calendar/0.4a1. 

I created an event at 2007-02-20 00:55 and set the alarm to 8 hours before. At 2007-02-19 16:55 the event fired on time.

John, can you export the single event in question to iCalendar format and attach it here?
(Reporter)

Comment 2

12 years ago
Created attachment 255686 [details]
Appointment for 4pm with 8 hour pre-notify

It's entered as a "Task" (though I should have made it an "Event").  But it happens no matter what day I place it in.
Attachment #255686 - Attachment mime type: application/octet-stream → text/plain

Comment 3

12 years ago
Can't confirm this on 0.3.1pre2. The alarm fires at the correct time, not on 18 hours ahead...
The start time of the attached task is set to 2007-02-19 04:00 am (America/New_York). The alarm was dismissed 2007-02-19 15:01:13 (UTC), that is 2007-02-19 10:01:13 (America/New_York).

For me it looks like the alarm for the task scheduled at 4am was fired as soon as Sunbird was opened because the alarm was already elapsed. 
I see no indication that the alarm was fired 18 hours ahead.
(Reporter)

Comment 5

12 years ago
Your right.  I failed to see that.  Sorry.  Again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.