Crash when focusing the input of an isindex and then reloading the document

RESOLVED FIXED

Status

()

Core
Layout
--
critical
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: Nickolay_Ponomarev)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows XP
crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Created attachment 255743 [details]
testcase

See testcase:
- Focus the text input of the isindex element
- Reload the document

Result: crash
It doesn't happen always, just try it another time, it happens fairly often.

This regressed between 2007-02-18 and 2007-02-19:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-02-18+05&maxdate=2007-02-19+09&cvsroot=%2Fcvsroot
My guess is a regression from bug 257868 since that patch is touching isindex files.
(Reporter)

Comment 1

11 years ago
But I guess this might be a regression from bug 368549, instead.
I locally backed out the fixes for bug 368549 and for bug 367779 and I can still reproduce this.
Backing out the patch from bug 257868 fixes this for me.
(Assignee)

Comment 4

11 years ago
Now that I null out mInputContent in nsIsIndexFrame::Destroy, the event listener is not destroyed in the destructor.

Interestingly, I can't create an auto-test for this, since it doesn't appear to be possible to focus the isindex from a script (?). I could use some help with this.
Assignee: nobody → asqueella
Flags: in-testsuite?
(Assignee)

Comment 5

11 years ago
Created attachment 255770 [details] [diff] [review]
patch
Attachment #255770 - Flags: superreview?(roc)
Attachment #255770 - Flags: review?(roc)
(Assignee)

Comment 6

11 years ago
Created attachment 255771 [details] [diff] [review]
patch
Attachment #255770 - Attachment is obsolete: true
Attachment #255771 - Flags: superreview?(roc)
Attachment #255771 - Flags: review?(roc)
Attachment #255770 - Flags: superreview?(roc)
Attachment #255770 - Flags: review?(roc)
Attachment #255771 - Flags: superreview?(roc)
Attachment #255771 - Flags: superreview+
Attachment #255771 - Flags: review?(roc)
Attachment #255771 - Flags: review+
(Assignee)

Comment 7

11 years ago
mozilla/layout/forms/nsIsIndexFrame.cpp 1.87
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/integration/mozilla-inbound/rev/0bb00fdf5447
Flags: in-testsuite? → in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/0bb00fdf5447
You need to log in before you can comment on or make changes to this bug.