Firefox hangs the computer with 99% CPU utilization after http://news.sohu.com is loaded

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: songrjx, Unassigned)

Tracking

({perf})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

115.30 KB, application/x-gzip
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Firefox hangs the computer with 99% CPU utilization after http://news.sohu.com is loaded.  I can view the website with less than 10% CPU in IE.

Reproducible: Always

Steps to Reproduce:
1.browse to http://news.sohu.com
2.
3.
Actual Results:  
99% CPU, need to kill firefox.

Expected Results:  
just like view the website in IE
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070219 Minefield/3.0a3pre
It uses 60% CPU here.
With the extension Adblock Plus it goes back to 4%.

Updated

11 years ago
Duplicate of this bug: 384552

Comment 3

11 years ago
Happens on Linux as well. Disabling Flash r64 doesn't help the cpu usage.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
OS: Windows XP → All
Version: unspecified → Trunk

Comment 4

11 years ago
Created attachment 286546 [details]
jprof profile

Comment 5

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008062005 Minefield/3.1a1pre

It works for me (3.1a1pre)

Thom

Comment 6

10 years ago
WFM also with and without flash
flash player 10
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081125 Firefox/3.1b2 

  songrjx, please reopen bug if you see problem with latest versions of flash and Freifox
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.